Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 24 Hours Last 24 Hours Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Articles Articles
  • onkelmicke's Avatar
    Yesterday, 11:30 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    Upon visual inspection of the EVO I can't tell if there is anything missing. Will test resistance tomorrow.
    19 replies | 162 view(s)
  • onkelmicke's Avatar
    Yesterday, 11:25 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    OK, I just figuered that the holes had some function and could have been clogged to cause problems. I don't yet know where the spring went,...
    19 replies | 162 view(s)
  • KMT's Avatar
    Yesterday, 11:06 PM
    KMT replied to a thread Steering jam in Technical Forum
    The valve is actually a piston that shunts to a different position, altering fluid flow thru the housing that holds it, based on inputs. The result...
    19 replies | 162 view(s)
  • onkelmicke's Avatar
    Yesterday, 10:18 PM
    onkelmicke replied to a thread water pump in Technical Forum
    My heater isn't working either... but the other day the car drank the coolant overflow container dry, haven't done that before. So I will have to...
    6 replies | 70 view(s)
  • onkelmicke's Avatar
    Yesterday, 09:51 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    About the valve... how to check it... should it let air through in one way? (Can't blow through it manually anyway.) No the tube isn't done...
    19 replies | 162 view(s)
  • TBirdSC89's Avatar
    Yesterday, 09:48 PM
    TBirdSC89 replied to a thread Steering jam in Technical Forum
    were you able to get the s/c tubing out? i might be wrong but isnt there 2 locations where the tubing connects to the engine besides the intercooler?...
    19 replies | 162 view(s)
  • KMT's Avatar
    Yesterday, 09:43 PM
    KMT replied to a thread water pump in Technical Forum
    Don't forget to rent a power steering pulley puller. I remember those hose stiffener springs. Haven't seen them used with replacement hoses on our...
    6 replies | 70 view(s)
  • onkelmicke's Avatar
    Yesterday, 09:42 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    OK, thanks, I will have to see if I can get them. Well...
    19 replies | 162 view(s)
  • KMT's Avatar
    Yesterday, 09:31 PM
    KMT replied to a thread Steering jam in Technical Forum
    Just noted the photo, thanks. Yes, remove the stud too, not just the nut. The tube needs more freedom to move before it will disengage from the...
    19 replies | 162 view(s)
  • onkelmicke's Avatar
    Yesterday, 09:30 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    Haven't reinstalled the pulley, still trying to get the pump out. Going to try to screw that pin out next. (If I understand it correctly.)
    19 replies | 162 view(s)
  • FurryWrecker911's Avatar
    Yesterday, 09:17 PM
    Yeah, I'm learning this myself the hard way tonight. It's the only way I've jacked up the Escort, my brother's Focus, and my roommate's Yaris, but...
    2 replies | 55 view(s)
  • TBirdSC89's Avatar
    Yesterday, 09:07 PM
    TBirdSC89 replied to a thread water pump in Technical Forum
    Indeed many things in play. I just flushed the system out and put in some new coolant a few months ago and bled the air out via the bleeder bolt. But...
    6 replies | 70 view(s)
  • TSC89's Avatar
    Yesterday, 09:00 PM
    H Ira. I no longer handle the buying and shipping of the calendars. I provide a link to the printer when they are ready. This way people...
    5 replies | 342 view(s)
  • TBirdSC89's Avatar
    Yesterday, 08:57 PM
    TBirdSC89 replied to a thread Steering jam in Technical Forum
    when my evo sensor went to crap on me and kept leaking, i just removed it for good and installed the power steering line directly to the pump. didnt...
    19 replies | 162 view(s)
  • KMT's Avatar
    Yesterday, 08:51 PM
    After growing tired of the OE jacking points and always holding my breath they would bear up, it dawned on me they are, at best, suited only for the...
    2 replies | 55 view(s)
  • FurryWrecker911's Avatar
    Yesterday, 07:43 PM
    First time with the Tbird that I was able to lift it in my own garage. My goal was this: clamp down the heat shield on the muffler to stop the...
    2 replies | 55 view(s)
  • onkelmicke's Avatar
    Yesterday, 06:22 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    Well, no I don't have any spare parts other than a remanufactured pump. I don't know anything about a teflon seal. I would like to get hold of any...
    19 replies | 162 view(s)
  • KMT's Avatar
    Yesterday, 05:59 PM
    KMT replied to a thread water pump in Technical Forum
    What did that include, exactly? Lots of little things are in play...some are common and some are unique to the SC, from the chin spoiler to the...
    6 replies | 70 view(s)
  • TBirdSC89's Avatar
    Yesterday, 05:46 PM
    TBirdSC89 replied to a thread water pump in Technical Forum
    Hey Ken I worked on the cooling system a few months ago while I was doing a tune up. It did seem to leak a little but it wasn't noticeable anywhere...
    6 replies | 70 view(s)
  • KMT's Avatar
    Yesterday, 05:46 PM
    KMT replied to a thread Steering jam in Technical Forum
    Outside of a visual check to see if the spring is ok and the valve doesn't stick, I'm not sure how to test off the car. If you had a known good one,...
    19 replies | 162 view(s)
  • pposl's Avatar
    Yesterday, 05:21 PM
    Is this SC still available?
    2 replies | 204 view(s)
  • onkelmicke's Avatar
    Yesterday, 04:34 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    I have the EVO out, but I'm not sure what to do with it. It has to be the main offender. I haven't been able to get the pump out. The lower...
    19 replies | 162 view(s)
  • FurryWrecker911's Avatar
    Yesterday, 02:39 PM
    FurryWrecker911 replied to a thread Radiator in Technical Forum
    Yeah, I've heard the same song too, usually tagged along with "It might last you 20 miles, it might last you 20,000 miles. It's just a patch job" and...
    2 replies | 105 view(s)
  • CougarXR/7's Avatar
    Yesterday, 02:12 PM
    ....trying to see if son in law and I can rent or borrow a trailer and arrange a dayn to drive down there. Have not been in Quincy since the mid...
    23 replies | 1676 view(s)
  • KMT's Avatar
    Yesterday, 11:06 AM
    KMT replied to a thread water pump in Technical Forum
    Sounds like the snout seal in the pump gave up. Might have caused a gradual coolant loss that eventually led to more and more symptoms, as opposed to...
    6 replies | 70 view(s)
  • Ira R.'s Avatar
    Yesterday, 07:54 AM
    Hi Jim. I'll take two!
    5 replies | 342 view(s)
  • TBirdSC89's Avatar
    Yesterday, 05:23 AM
    TBirdSC89 started a thread water pump in Technical Forum
    Just wanted to post some water pump issues I came across. I noticed steam from the hood but the weather has changed colder here in Oregon so I didn't...
    6 replies | 70 view(s)
  • TSC89's Avatar
    11-16-2018, 11:42 PM
    The calendar has been submitted to the printer and I am waiting for the proof copy. It should take about a week.
    5 replies | 342 view(s)
  • KMT's Avatar
    11-16-2018, 07:21 PM
    KMT replied to a thread Steering jam in Technical Forum
    I've seen used ones turn up here. If it comes to that, try a want ad, being sure to mention your location ;) Might be worth checking the two fuses...
    19 replies | 162 view(s)
  • onkelmicke's Avatar
    11-16-2018, 05:11 PM
    onkelmicke replied to a thread Steering jam in Technical Forum
    Hmm... interesting threads, thanks. Will try and disconnect the EVO. Don't have codes or such, but will have to look into it. Coincidentally...
    19 replies | 162 view(s)
More Activity