PDA

View Full Version : my blower is gone!!!



turbospeed
09-19-2002, 02:14 AM
after a tune up replacing some sensors and everything i still didnt get boost so i checked the SC fluid and poured almost the whole bottle and still didnt fill soi dont know how much the other guy has been driving it like that i just got it 2 weeks ago....the damn idiot havent chaged the oil in 6 yes 6 months and the spark plug seems to the the ones that came from the factory damn old and burned well i wil try to get a j/y one

David Neibert
09-19-2002, 09:13 AM
Check to make sure the hose for the boost gauge didn't fall off. It's very small hose that attaches to the intake manifold adaptor just below the ACT sensor. I had to zip tie mine to keep it on.

The only other thing that would prevent you from getting boost is if the linkage for the bypass valve is stuck against the back of the SC top. It fits close and can sometimes bind. It should open when car is started and close about 10 seconds after you shut the car off.

David

hepcat
09-19-2002, 04:57 PM
What you need to do is take off the sc belt and turn it by hand back and forth. There should some resistance and more if you turn it faster. If it turns pretty easy then some inside may have broke not alowing the sc to spin. If the blower rotors seized then the shaft coming to the rotors has three ends that go in to the rotor gears they might of broke if enough force was applied. So the front would spin but the rotors would not But I would thing you would hear a noise unless it has been that way for along time and just settled in.

the bypass valve is a major thing that would cause no boost so while the engine is running rev the engine and look at the lever and while you give it gas it should close and come to rest on the lever stop. This closes the bypass alowing for boost when you are driving the car.

Hey does the car have power though. When you floor it does it push you in your seat or is it a light acceleration?



Raymond

turbospeed
09-19-2002, 09:51 PM
it bogs down and then normal acceleration like my moms LX 3.8n/a in case i need a rebuilt where can i find a kit? i found a guy who rebuild blowers for drag cars and he told me hes gonna chargeme 100 bucks for rebuild it where can i find a kit?

Matt SC ESC
09-20-2002, 02:45 AM
turbospeed, i have a whole blower for sale if you are interested... if not... best of luck to you...

turbospeed
09-20-2002, 03:25 AM
how much do you want for the blower?

N60OSU
09-20-2002, 11:51 AM
It sounds as though the blower is OK. I've had both a snout bearing and a rotor bearing go bad on seperate occasions. Both times there was little doubt that there was a problem. If the blower was bad I'm pretty sure you would be able to hear it.

It does sounds as though your bypass may be stuck open. You will get some assistance from the blower even with the bypass open. It doesn't completely close off the blower. If the blower was not turning, it would seriously restrict airflow through the IC portion of the intake. Again, the bypass does not completely close off the blower, and intake vaccuum will pull some of the air through the blower/IC. Too much throttle under that scenario will kill the motor as the bypass closes. Engine vaccuum alone is insufficient to draw adequate air through the stationary rotors to keep the engine running. With the bypass open and blower turning, you've basically got a very light pressure supercharger.

The SC is geared for 300+ lbs of tourque at a very low RPM. Without a little help from the blower, the motor will initially bog down in the low 1st gear. Once it gets going, though, it will just seem slow. Try putting a few RPMs on the motor while holding the brake before rolling out of a stop. That will get some torque in place to get the car rolling.

If you decide you need to rebuild the blower, e-mail. I've done three snouts and one blower. I've got all the part numbers you will need and can give you some direction so you don't make some of the mistakes I did...

turbospeed
09-20-2002, 04:28 PM
well i took the carto chek today with a guy that specializes in blowers he said that everything sounded fine but he didnt took it apart because he didnt had time but he said seemed like the air bypass was stuck i hope so....but just in case how much you want for the blower?? i will e-mail you later

update :
i was messing with the car after i came from the shop and i had the idea of put a zip tie in the bypass to let it closed.and it worked!!! i only got 10psi but what a difference !!! well i got a offer of a blower for 150 so im gonna get it and keep it for later porting etc..........man im happy!!!

Bill
09-30-2002, 12:55 AM
I have a freshly rebuilt (by magnum power) supercharger from a 1990 Supercoupe I will sell for $300 and I'll throw in the inlet plenum and $50 worth of extra fluid. You pay the shipping.

tbird88
09-30-2002, 10:47 AM
turbospeed...

I noticed you are in Mexico. Was your car originally sold in Mexico or did you (or the former owner) buy it in the states? If in Mexico, can we please (please!) see some pics of it? I'd like to know if there might be any small/unique differences in our cars.

de Tejas, tenga un día agradable!
(from Texas, have a nice day!)

'bird

CaifanSC
10-01-2002, 01:06 AM
Tbird88, as far as Im concerned, the SC's down in mexico are exactly teh same as US sc's. I've verified with some one whose doctor in Mexico drove a 1990 5speed, and it was exactly the same (compared to my 89). I have no clue if the 35th anniversary option was offered down there, but there are a few things that are intreaguing. Like the years the sc' was produced in Mex. and for how long. I remember a while back there was an engineer for GE Mexico who posted a few questions on the old old bbs, and he had a 1995 SC'd cougar XR-7 from factory, and he told me that SC'd XR-7's had been produced in different yrs than the us (i think 92-95), but he did not know about SC's. I have No clue on production #'s either. Im also not completely sure about where the Mexican SC's where built, Im assuming they were exported into mex. from the U.S because the only thing that I know ford actually makes in Mexico are heads and other engine parts, but no actuall assembly of cars. I'll be sure to try and investigate something when I go down to Mex this winter.

turbospeed
10-01-2002, 11:59 AM
well mine was originally from the US but i have located a 93 cougar XR-7 SC 3.8l ( it was for sale like a week ago ) and a 1989-1993 SC originally bought at mexico ( they have different plates) i will try to talk to them and get VIN and pic of them

Matt SC ESC
10-01-2002, 03:21 PM
85-90% of ALL Ford/Motorcraft parts are either assembled, or made in mexico. Last I heard GM was trying to put a plant in a small town just outside of Mexico City. (guessing that's where Ford's is).