PDA

View Full Version : Ok Bryan, diags say!!



kamakazie_1
02-24-2009, 10:48 PM
Looks like a 214 code Bryan, that's the best I can read that little blinky lite bugger..

CID circuit failure.. Oh JOY!! :mad::confused:

I guess, DIS or Cam sensor or crank sensor...

RJ

Cobra85
02-26-2009, 09:18 PM
I'm going with the cam sensor. I did the 93 the other month when it was acting up and 214 was the same code thrown. Replaced the cam sensor and all problems gone (for now:D )

kamakazie_1
02-27-2009, 01:38 AM
Thanks Glen, did you guy a new Ford part or aftermarket?

RJ

SuperChicken89
02-27-2009, 11:17 PM
Thanks Glen, did you guy a new Ford part or aftermarket?

RJ

Even if you buy an afternarket part, it appears to be made by the same manufacturer as the Ford one. They just grind off the ford part # and logo.

You may be able to pull the one off of the 90 Anniversary to test with. I think they are the same.

Bryan

kamakazie_1
02-28-2009, 08:59 AM
I went ahead and got the aftermarket, it looks like it might be fixed (fingers crossed) it ran really well last night after I changed it.. I still need to get plugs and wires for this thing too.. What plugs are everyone using now?

RJ

SuperChicken89
02-28-2009, 01:56 PM
I went ahead and got the aftermarket, it looks like it might be fixed (fingers crossed) it ran really well last night after I changed it.. I still need to get plugs and wires for this thing too.. What plugs are everyone using now?

RJ


On the plug wires, check with Dan. He had to buy a new set and Greg suggested where to purchase them for like $20. I think Greg suggested the Duralast wires.

I can't recomend a direct replacement plug. I am running the el cheepo Autolite 103's gapped at .30" per Mr. Dalke's advice.

Bryan

onequiksc
03-02-2009, 12:15 AM
Haven't bought them yet, but plan to this weekend upcoming.

Greg's input suggested they work just fine, he's had no issues with his.

$22 he said. Worth a try IMO, and I will be trying them. I've had Jacobs wires the last 10 years and one ripped on me upon tearing the motor down, so I am open to something else and don't want to spend $100+ again.

Duralast at A/Z.

kamakazie_1
03-02-2009, 07:50 AM
Ok, thanks Dan, Dave Niebert on the board here suggested a Taylor set to some person, he had the link from Summit, I looked at them and they looked like $45 plus no shipping right now... I didn't figure that was a bad price, but $20 is much better as long as they work well enough.. I noticed on Summit's site they also had our DIS coil packs, direct replacement and Accell super coils direct replacements, they weren't too expensive. They also have the replacment crank sensor and the little piece of harness with them.. I got the CPS from AZ and it seem to fixed the cutout problem so far. Drove the bird to Tampa and then all over the place down there on Saturday and it performed will, still feels like a little miss... I have to get this tranny swapped out now, it acted up a couple times while we were out..

RJ