PDA

View Full Version : need help asap please verry high idle!!



dabs
04-11-2009, 11:48 PM
Hi peeps,
I just picked up a 89 sc 5 speed it has a few things I need to take care of but the thing that has me baffled is the high idle were talking 2.5-3k at idle but during driving conditions say 70mpr im at 1400 I read though the forums and checked a few things thanks to everyone on here with there post, I didnt find a leak but I think a vacume leak would give me high idle but not this high. It came with a few maf’s in the trunk the one on it looks like some one took a hammer to it so I tried the others still same results one of them is in here the # for this one is f4sf-12b579-aa all of them have different numbers if some one could give me the number on theirs so I can make sure I have the right one that may help. If not any suggestions would be appreciated. Most of the other things I can fix but this one has me in knots also its hard to shift it could be from the high idle but I may have to change the clutch master cylinder but not sure until I get the idle down.

Thanks for the help

QuickMustang
04-12-2009, 12:15 AM
If I had to had guess, I would say it's your idle air control valve. It's mounted to the side of your throttle body. A vacuum leak wouldn't raise your idle because you would run really lean.

TSC89
04-12-2009, 12:19 AM
I checked my 5-speed and my automatic on the MAF, the part number on both of them is: E9SF-12B579-AA.

I don't know if this related to your idle problem but it will cause other problems.

dabs
04-12-2009, 01:05 AM
thanks for the model number on the maf and i do belive its the iac like on all the threads not a vacume leak. i do have a few iac's from regular 3.8 not a sc and they only differ by a black dial on top that i guess u can adjust. i believe the iac is the black and silver thing right by the tb close to the air intake hose is this right? the ones i got at the junk yard were all plastic can they be used or do i need a different one. i also read that the ones from discount auto stores sell the wrong thing and that i have to go to the dealer is this tru or did any one else have good luck with the discount ones. there a special order and u dont get a refund if its wrong so i dont want to waste my money thats why i tred the junk yard today i looked for a maff too but i already have 4 and i believe there all the wrong number.

thunderkid84
04-12-2009, 01:23 AM
put the stock maf in and disconnect the battery for abot 20 mins. while its off take a look at the IAC and see if u can find the ford symbol on it or if one of your spares has it. the IAC is the bigger of the 2 sonsors on your throttle body.

reconnect your battery, start it, and see if it will idle down. if not take it out on a drive and let it re-learn everything and see if that helps.

carlislesc
04-12-2009, 03:34 AM
I had this problem last summer. The idle was very very high in 1st and second, but was normal in 4th and 5th gear. I thought I was going to blow the engine before I got it home.
The 90SC was serviced at a Ford dealer. It was the IAC valve assembly. Part number on invoice FD F4ZZ / 9F715/ AA. $170.96 new dealer part and 1 hr labor.

Raymondo
04-12-2009, 10:10 AM
Yep, sounds like the IAC to me as well. I had a similar problem with my '92 and my son's '93...changing the IAC solved the mystery. I also reset the computer by disconnecting the battery for a while.

QuickMustang
04-12-2009, 04:22 PM
I got my replacement IAC from Advance auto parts. It worked great, and is still on the car...