PDA

View Full Version : i need help fast **UPDATE**



franky_402
05-09-2009, 09:47 PM
ok heres the thing, dont get mad at me its stupid i know, but anyways heres the deal. I got drunk last night and stupidly drove my car, coming into my apartment complex i hit and drove up on the bridge side. i fubarred my fender, cornering lamp and scraped the front bumper pretty bad. I just went to go look at it for the first time about an hour ago and noticed the battery was dead i think i sat thier and listened to music before i came in i dont remember so i get the car jumped and its running good for a minute or so and i start to rev it up to charge the battery good and then the car starts stumbling a little and catching itself and wasnt sounding good so i ran to shut it down and noticed there is a lot of liquid coming out of the exhaust, it doesnt really smell like anything and the oil is a little on the low side(right at the bottom of the cross-hatching) but its clean. And the radiator is low. so im thinking i blew the headgaskets but not sure how in the hell that could happen from my mishap. To top it off my bank account is negative, and im currently un-employed. And my phone just got shut off last week, im so screwed if they did pop. Anyone got any ideas and things to do and not to do i really appreciate it.

decipha
05-09-2009, 09:53 PM
sounds like the supercoupe gremlins are teaching you a lesson

probably nothing wrong with the car its just its way of telling you that it doesn't appreciate what you did

Sounds like your alternator is on its way out, could have been discharging that battery and that extra strain of listening to the radio depeleted it. If its running and the battery voltage drops too low it'll start freaking the computer out and causing it to run crappy. I'm willing to bet that you'd be alright just swap in a fresh battery and try it out. The fluid leaking out the exhaust could have just been moisture.

good luck with the supercoupe hope the worst didn't happen to ya

franky_402
05-09-2009, 10:08 PM
i was kinda thinking that it could be running like crap due to low voltage but its not like there was just some liquid coming out it was quite a bit. I am also very afraid to try and start it up again as if the hg's did go i dont wanna ruin the engine. im so pissed off at myself for what i did, i hate driving drunk and cant believe i did that, but i guess thats gods way of telling me you drive drunk and ill mess with the thing you love dearly. also no airbags so im guessing i wasnt going that fast.

tydlwavs
05-10-2009, 09:40 AM
I got a headlight mounting panel from another member a while back. It has a crack in it, but just between the hood latch and one light in the very front....nothing that will deter it's use in your car. You can have that if you come pick it up.

I don't have anything else that you need, sorry.

Todd

CougarXR/7
05-10-2009, 11:01 AM
Hey Frank............contact Mark.....scbird1..he has a fender and some other parts you may need.

I have a bumper that needs attention to the scratches in it. I got it from Mark.........let me know if you want it. just pick it up.

franky_402
05-10-2009, 01:41 PM
Hey guys thanks alot, i reallly appreciate it, and im sure the crack will be fine enough, are you going to the next meeting todd?? Maybe i can pick it up off of you then or we can meet up before then.

franky_402
05-10-2009, 04:25 PM
does anyone really think my engine shouldnt be ok to try and start again?? I really want to make sure but im just afraid at the moment, what do you guys all think

Raymondo
05-10-2009, 04:36 PM
If the engine was just stumbling and not rattling, knocking or smoking you are probably ok. Low voltage, a disconnected ground cable, or a vacuum leak could cause the stumble. Also, it could just be pissed off at you! LOL

If you blew a headgasket you would see water/antifreeze in the oil, lots of white vapor in the exhaust and it would smell like burning antifreeze.

franky_402
05-10-2009, 04:39 PM
ok the thing that is just really worried me is the amount of liquid that came out of the exhaust but maybe im just over thinking cuz im scared that i broke it

franky_402
05-10-2009, 07:00 PM
So i got the courage to go outside and look at my car again, i get in i start her up and boom she is running like total ~~~~~,

so i wanted to move it closer to my apt building so i back out and it just violently shaking the whole time and stumbling, i put it into drive and start to go same thing, shaking, stumbling, rough running, im thinking vac leak!

Then i push the gas a little further the boost guage goes to around 5 lbs and she died but then caught herself as soon as i let go of the gas. I make it to my parking spot of choice and put it into park. I wait a second and the idle seems to smooth out some so i rev it up a little and sounds better

I take it for a drive around the complex, easy if course, i push down on the accelerator, and she moves damn good but when i let go of the gas the idle drops pretty low and stumbles for a second (down to about 450) im guessing it was just a low voltage situation,

I'll take a different battery and put it on a slow charger for tonight, im still really upset with the body damage however

Young-SC-Owner
05-10-2009, 07:46 PM
Im glad your ok,
Now that I said that.....Maybe you shouldnt have been driving drunk:rolleyes:
so...No help from me but ill bet it has something to do with the "whatever it was" you hit

franky_402
05-10-2009, 08:16 PM
yeah i know i shouldnt have been driving like that, i was consuming vodka and things got outta hand with some bitchy girs and i was told to go home or lay down and i guess i picked to drive home, i dont remember any of it and thats the stupid choice i made, something must have crossed my concentration pulling into my apartment complex cuz i drove the other 2.5 mles home just fine, just pulling into the last 100 feet or so i hit the bridge wall, and drove up on it. When i pulled in i must have sat and listened to music and killed the battery completly. But im fine and so is the car for the most part besides cosmetics, lesson definelty learned

LordBear
05-10-2009, 08:16 PM
ok...u might have an hg out..so i would have it checked out but first thing i wld do is go get some spray cleaner of some kind that is safe with sinsers... then pop ur hood find ur air filter and right behind that is a a airflow sensor... carefully unbolt that and clean it reall good but the sensor and the holes and so forth in the piece u unbolted from..when dry put it back togethor..unplug ur battery for a while..then put back togethor and start it back up and see what happens...

franky_402
05-10-2009, 10:32 PM
im not thinking its the h/g anymore, i think it was the low voltage throwing the computer off, like i said after about a minute or two runing it smoothed out and was pulling hard again.

Melon
05-10-2009, 10:40 PM
You said you checked the fluids, I would top them off and then watch them over the next few days. Especially if you weren't aware of a fluid leak prior.

And 2nd - even though you already know it - don't drive that way. Eventually it's going to catch up with you. It did with my friend after she wrecked her truck going home - she got lucky with the whole thing, no one else was hurt and she just had a concussion and [b]walked[/b[ out of the ER the next morning when her dad picked her up. Your lucky it's just the car against a wall and not a potential hit and run. Yes, end of lecture :p

Hope the car is ok and things work out :)

-Melon

franky_402
05-10-2009, 10:53 PM
i know i got really lucky, and im still beating myself up for the stupid choice i made, i know that the rad has a slow leak somewhere but have been watching up untill recently so im sure thats fine. over the winter i never really drove it and therefore didnt check it much, a new radiator is on my top priority when i get my finances situated soon. it does seem that the oil level drops a little bit in between oil changes, not sure if its cuz of the boost or its burning oil, i never get blue smoke upon starting or anything like that, maybe run a thicker oil 10-30?? i also use mobile 1 full syn. every 2500 - 3000 miles