PDA

View Full Version : no dash lights



91supacoop
05-28-2009, 10:23 AM
The dash lights do not come on when i turn the headlights on. The taillights do turn on. Any thoughts?

RedSC93
05-28-2009, 10:30 AM
Might sound dumb but turn the knob to the left, something might of turned the other way. My kids have done this in the past. Or check the fuse box


Jerry

whiplash15
05-28-2009, 10:55 AM
If you still have no dash lights, check the fuse for the tail lights. They are likely on the same fuse. Still no dash lights, there is a ceramic potentiometer on the front end of the light switch that is (in most cases) replacable separately from the complete switch.

jonroe
05-28-2009, 10:58 AM
No, the dash lights have their own fuse in the panel above your left foot. I'm in a condition where this fuse keeps blowing because there is a chafed wire somewhere near the manual gear shift. If I stay out of first, no fuse blow - if I put it in first, fuse blow. I haven't taken apart the console to look for it yet.

TinManSC92
05-28-2009, 06:30 PM
yep! that's exactly what happened to me. took the console out and fixed the wire. perhaps too many HARD shifts.;)

sts70004
05-28-2009, 07:31 PM
I had a similar problem on my 1990 Tbird, and it turned out to be the dimmer switch, which is also the headlight switch. I pulled it off and then opened the switch and what it was a circular spring that was a resistor, and then as you rotated the dimmer switch, it moved a metal contact over the spring to change the resistance. On mine the metal contact had worn down and lost contact with it. After cleaning and a little bending, it was good as new.

If your fuses check out, and simply turning the dimmer switch doesn't fix it, its pretty easy to pull it out and look at, so I'd do that next.

jonroe
05-28-2009, 08:23 PM
yep! that's exactly what happened to me. took the console out and fixed the wire. perhaps too many HARD shifts.;)

If I ease it into first it won't blow but if I slam it in it will. I ALSO noticed that with the radio on and a non-slam into first I could hear scratchy interference in the radio as the wire must be grazing metal. I'm sure this is my problem.

Could you please give me some more details on exactly what you did and where the bad wire was? That would help save time. How hard was the console to get out?

Thanks!!

91supacoop
06-19-2009, 06:41 AM
::Follow up::

The culprit was a wire that goes to the light for the ashtray. I replaced the fuse, and the wire (under the center console going from the armrest towards the climate control unit) and all seems good now.