PDA

View Full Version : Wierd main fan problem



Pablo94SC
07-25-2009, 06:17 PM
My main fan decided to quit working on me yesterday while I was at the track. Fuse was good so I pulled the ECT. Fan didn't kick on so I limped the car home with the pusher fan running (I have a 94) and occasionally the heater to keep the car below M. Get outside today to properly test everything. Both fan windings fired up when jumped directly off the battery, so that's good. KOEO test cycled both windings, so the IRCM and wiring is good. ECT trick worked. I'm glad it's working, but stumped as to why it happened. Anyone ever experience this before?

Duffy Floyd
07-25-2009, 06:53 PM
Could be the IRCM relays are beginning to go intermittent.

Pablo94SC
07-25-2009, 10:10 PM
Could be the IRCM relays are beginning to go intermittent.

I thought about that. Also thought I might have a bad wiring connection from where I spliced into the harness when my first IRCM went south. Wires all checked out, so it's probably the IRCM. I need to brush up on my electrical schematic knowledge so I can bypass the relays in the IRCM with external ones. There happen to be a write-up on here about that, or will I be the one writing it? :p

Duffy Floyd
07-25-2009, 10:14 PM
I've seen one written on how to replace the stock relays. Might want to consider that before you have external relays hanging around that area exposed.

Miller
07-26-2009, 10:09 AM
I had my fans go out on me at the track also. Luckily I have no faith in my car, so i was able to temp wire it right to the battery with my random assortment of goodies I never leave home without. I changed the icrm and fans still never worked. it is now bypassed with all new wiring and a switch and no worries now.

Pablo94SC
07-26-2009, 12:12 PM
That's odd that changing the IRCM didn't fix the problem. Did you ever check to see if the 60A fuse or the wiring in the power distribution box (PDB) wasn't fried out? That's what originally happened to mine and one of the places I checked. I got a 60A mega-fuse holder from a car stereo shop, connected it to the side terminals on the PDB and spliced the wiring into the power wire to going to the IRCM/fan. Been working great ever since.

Duffy...

I had my fan running off a thermo-electric switch and external relays for quite a few years without any problems, so I feel confident in saying it's a pretty safe modification. But to be on the safe side, I'd also recommend carrying a spare relay in the glove box. ;)