PDA

View Full Version : Oil pressure and firm ride



daveo1021
08-02-2009, 12:31 PM
well i just changed my master cylinder for the breaks... ever since then i replaced the break light switch and seems to work fine but now the firm ride light goes on and off.. so i just put it on firm ride all the time.. any ideas on that one let me know... now.. the oil pressure gauge goes way down untill i press on the gas then it goes to normal.. of course when the oil pressure gauge goes down the check gauges light comes on ..but i was just wonder what the heck was goin on.. check the oil and all fluids everything seems to be runnin good .. also when the ol lady drives it she says it dies if shes in reverse .. every once in a while..
Dave*O:rolleyes:

rickbtbird
08-02-2009, 12:39 PM
Count the flashes and when it pauses you know which actuator to clean.

the-big-e
08-02-2009, 01:16 PM
I'll bet you forgot to plug the actuator on the DS fender back in after you did the master cylinder repair.....;)

Check the connection to the oil pressure sending unit....

daveo1021
08-02-2009, 01:26 PM
im not a mechanic really haha i just try to do stuff on my own.. half the time it works out crappy.. what's a ds? oh and would the oil sending unit connection be close to the starter.. i just switch that out too .. may have forgot to connect it ? lol ongoing patterns i see

the-big-e
08-02-2009, 01:53 PM
DS = Drivers Side.....

The oil sending unit (looking from the front of the engine) is buried down on the right side of the water pump.....

You will see a single wire going to the sending unit...

daveo1021
08-02-2009, 01:55 PM
awesome ..ill check it out when the wife gets home..thank you..

dbd
08-02-2009, 02:50 PM
Picture

http://www.sccoa.com/forums/showpost.php?p=739458&postcount=3

dbd