PDA

View Full Version : EATC repair help



bowez
09-27-2009, 05:47 PM
Has anyone ever take apart the side of the panel with the selection button and that has the vacuum ports? Electrically mine is working just fine, but it will only blow to defrost vents, but temp operates properly. I swapped out with the 5.0s (since going to be down for awhile) and proved its not in the system just the selector side of it.

I tried to open it up, figuring have stuck vacuum selector, but get about 1/4 open and it just gets stuck.

Melon
09-27-2009, 05:51 PM
I haven't messed with the early style (I believe you've got a 93, right?) but had issues with the SATC in my 94. It ended up being a vac line under the hood - I believe it was near the passenger side. It could be something to look at?

-Melon

J.D.
09-27-2009, 08:39 PM
Defrost is the default position when the vacuum level is too low.

The vacuum section with the selector buttons can easily be unclipped from the EATC unit. However, even if you succeed in opening up the vacuum unit without breaking the tabs that hold it together, the internals will fall out and you will not know how to put them back. It is similar to assembling a valve body in an automatic transmission, with the main difficulty being that the components are extremely tiny and you will not have a diagram of their locations.

I'm not sure if the vacuum unit in the EATC is interchangeable with the one from cars with manual climate controls. My 1992 Owner Guide shows slight differences in the labeling on the buttons.

bowez
09-27-2009, 09:34 PM
Is not a vac line, using the one form the 5.0 (both 93) and works just fine. As for interchange just looking electrical 93/94 look identical form factor is different though.

So I guess my next question is does anyone have a diagram of the vacuum unit, or how much am I looking at for a replacement?