PDA

View Full Version : The Thunderbird is back!



MrSnow
10-05-2009, 10:03 PM
On my friends trailer again..... FUUUUU!!!!! So heres how it went down.... I noticed my car wasn't pumping out hot air enough. I figured it needed a new heater core since the temp gauge wasn't too high. And it would sorta heat up after a bit.... if I left the engine running.....Also note that the oil pressure gage doesn't move from L side.... So I took it 100 miles down to a friends house. It was on the interstate when I heard a noise and of sorts and then the engine started to sound like a diesel engine. The yellow engine light came on then off then back on again. I stopped.... after a mile.... or two and looked underneath the car. She had radiator fluild all over the bottom of the engine bay and I had no water or anti freeze in the radiator.....
So.... is this my water pump blowing out? Or a hole in my radiator? It was raining and will check on it tomorrow when I can see in in the shop.... Was this caused by the heater core not working correctly or a thermostat problem? Its bad in my opinion.... Its 58 bucks for a new water pump....@ advanced auto and I wonder what a new radiator will cost me? Or is this a sign of a blown head gasket?
http://img7.imageshack.us/img7/4928/mediacardblackberrypictz.th.jpg (http://img7.imageshack.us/i/mediacardblackberrypictz.jpg/)

thunderkid84
10-05-2009, 10:47 PM
I think u might blown a radiator hose off if your leaking antifreeze everywhere.

But if it sounds like a diesel then u might have spun a bearing.

MrSnow
10-06-2009, 01:14 AM
I think u might blown a radiator hose off if your leaking antifreeze everywhere.

But if it sounds like a diesel then u might have spun a bearing.

Spun a bearing? Thats bad.... I hope not.... would that not be heard at lower rpms? I started today to get it on the trailer...after I put water into it. It seemed not to have any odd noises at the time...

MrSnow
10-08-2009, 09:46 PM
I was thinking of trying to put some radiator plug solution into the car tomorrow.... Will that work? Anyone got any recommendation?

kneedragger25
10-08-2009, 10:18 PM
I don't recommend it, It may clogg some ports in your radiator. I have seen plenty-o-cars with this issue.

thunderkid84
10-08-2009, 10:29 PM
i dont recommend dumping anything in the radiator either.

snow, can u make a video of the car running ? that would for sure help

TinManSC92
10-08-2009, 10:40 PM
that happeed to me. the deisel noise is probably a lot of water spraying the belts and everything else. i'll bet hole in rad or hose.

nickleman60
10-08-2009, 10:51 PM
Overheated............

MrSnow
10-09-2009, 01:46 AM
i dont recommend dumping anything in the radiator either.

snow, can u make a video of the car running ? that would for sure help

Done http://www.youtube.com/user/sodakproud#p/a So it was just a loose hose I think and the overheating in the radiator. This car is driving me nuts.... I'm pretty sure the check engine light was on as well permanently... LOLZ!
I'm thinking about getting a civic... Anyway I had already bought a new heater core for the car. Might as well replace the thermostat while I'm at it too huh? And that damn power steering pump.
-Da Snow

PS I'm fat because its cold up here. ;D

MrSnow
10-09-2009, 11:13 PM
Bumpity bump bump!