PDA

View Full Version : newest sc nightmare



specops_SC
10-09-2009, 04:43 AM
so a little while after telling my friend the story about the first time i lost power steering and almost put my SC into a concrete barrier, I have the same thing happen again. At least this time the good news is its not the power steering pump. somehow my crank pulley decided to start losing and shearing its retaining bolts that hold it to the balancer and the belt flew off the pulleys..

this only happened because i was happy i got some stuff done on my car. put in my new 76mm mafs, replaced the speedo gear so i dont have to eyeball my speed anymore, retightened my right collector (flange nuts are somewhere between here and muncie indiana :rolleyes:) and cleaned my windows! reloaded a stock tune on it, reset the computer and the car was running great. its lean at WOT but thats not a hard fix.

now i gotta pull bolt threads out of my balancer and hope its ok. for a while is sounded like the jackshaft pulley, then i thought maybe it was the sc bearings cuz it was sounding like marbles rolling around. then bam. batt light comes on, no power steering and its haul ~~~ home before the car overheats time. barely made it too. why do i bother? lol /endrant

:(:(:(

Moses

DrFishbone
10-09-2009, 07:55 AM
somehow my crank pulley decided to start losing and shearing its retaining bolts that hold it to the balancer and the belt flew off the pulleys..


Dang Moses...any idea why this happened? Did you torque the bolts down to the proper specs?

My car is making a sc bearing-type noise too, but it's somewhere else that I haven't found yet. Maybe I better check all the pullies real well before driving again. :eek:

I didn't realize you were at the shootout! Which car was yours?

NEEDaSCbad
10-09-2009, 09:54 AM
I never had the marble noise but thats exactly what happened to me....sheared my crank pulley bolts off at the balancer, lost power steering, lights dimmed.:confused: I saw what happened and had it towed in fear of causing more damage. I couldnt get the sheared bolts outta the hb:mad: so I just got a puller for a diesel and pulled the hb off, replaced with a bhj and then new 10% OD crank pulley cuz mine was trashed. When stuff breaks...upgrade right!:cool:

Good luck man.

specops_SC
10-09-2009, 11:07 AM
Dang Moses...any idea why this happened? Did you torque the bolts down to the proper specs?

My car is making a sc bearing-type noise too, but it's somewhere else that I haven't found yet. Maybe I better check all the pullies real well before driving again. :eek:

I didn't realize you were at the shootout! Which car was yours?

the bolts were german torqued matt. probably didnt help :o the sound got progressively worse very quickly, as in within a few miles of driving. I havent got the change to take a good look yet as it was 3am when this happened.

good luck finding your noise. hope you dont end up like me!



I couldnt get the sheared bolts outta the hb

man, i didnt even think about that possibility :eek: now i dont know if i want to go outside and look at it lol. thanks for the heads up though.

Moses

P.S. Matt, my sc was the one with the mostly peeled clearcoat and blue front bumper with flames coming off it. You mightve seen it being pushed off the track twice and towed raceday by a big white dualie

specops_SC
10-09-2009, 08:07 PM
got two bolt heads sheared off and a stud still in the balancer somewhere. guess i'll be buying a bhj balancer here soon. gotta love it :)

Moses

XR7Kurt
10-10-2009, 12:09 AM
Might want to check this out.
http://www.sccoa.com/forums/showthread.php?t=109963

DrFishbone
10-12-2009, 12:31 PM
Moses - I DID have a problem with my pulley/balancer!!! :eek::eek::eek:

Somehow I forgot about reading this thread a long while back...so if you end up buying a BHJ (I have the SFI approved one)...then take heed of the warning in this thread!!!

http://www.sccoa.com/forums/showthread.php?t=106322