PDA

View Full Version : My project is hopefully almost done!



91BLOWNBIRD
12-16-2009, 04:30 AM
For all you northerners that care and are still around...

my engine is back and in the car, just slowly puting her back together. I listed all my new mods (+ old ones) on my member page.

Who is still out there enjoying their birds (running or not)?

Here is my IC setup if interested, I posted earlier, still in progress:

http://www.sccoa.com/forums/showthread.php?t=111263

Ddubb
12-16-2009, 05:46 PM
Looks good. The best feeling is when you start it up for the first time and hear it run - thats always my biggest relief after a rebuild. :D

- Dan

91BLOWNBIRD
12-16-2009, 11:27 PM
I'm always scared that it wont start right off the bat, but there are so many things that could go wrong it is almost innevitable...I mainly worry about the damn timing (setting the cam sensor).

I guess you and I are the only northerners left Dan...?

Ddubb
12-17-2009, 03:52 AM
I started my engine the first time with no exhaust, just exhaust manifolds. Everything else was plugged in though, sounded NICE and LOUD.

I replaced a lot of things new, plugs, wires, etc .. but the car was running fine before I tore the engine out for a rebuild ( with the exception of the huge rod knock of course ). So there wasnt any reason to be another problem .... if your car was running fine before the HG's .. everything should be OK. :D

When I got it all running again, first thing my water pump went out - so had to replace that new. Then I had a check engine light for the Cam sensor, but it worked perfectly fine. Replaced that and the light has been gone and for the most part no problems since up until recently my power steering pump decided to quit working.

Thats the nature of these cars, get it running great, something else breaks. ;)

The northerners are here .. most are hiding out. There is some talk recently at TCCOA though, the guys from Nor-cal want to set up some type of meet in the near future.

- Dan

91BLOWNBIRD
12-24-2009, 06:51 PM
my bird is back...thanks to Dan and his last minutes heroics coming through with a JAckshaft Tensioner! Thanks again Dan!

It fired right up basically a whole new engine...just gotta smog and insure it now.

Ddubb
12-24-2009, 07:50 PM
Consider it an early Xmas present. ;)

- Dan

bgck7
12-25-2009, 09:58 AM
Hi Dan,

Cant wait to see your new beast, pics look great. cant wait to see it, theres a dino day with the svtoa guys in late jan, you should come along. ill post the invitation soon.

regards,
ramon:cool:

91BLOWNBIRD
12-26-2009, 07:50 PM
Here are some pics of engine bay

Ddubb
01-08-2010, 07:02 PM
Hey Jeff, I fixed that knocking sound ... turned out to in fact be the crankshaft pulley bolts, Im thinking I should loctite these things ... :eek:

- Dan

91BLOWNBIRD
01-08-2010, 07:42 PM
oh man yeah might not be a bad idea...pretty sure you dont want that thing flying off :eek: lol

It would probably eventually strip your balancer keyway so hopefully all is well

Ddubb
01-08-2010, 07:50 PM
Thats why I havent been driving my SC for the last couple months .. now If I can only fix these Coolant leaks ( at crossover tube near oil filter, and at the heater core hoses ) ... one thing after another. :D

- Dan