PDA

View Full Version : help still will not start



pickel69
03-05-2010, 11:29 PM
can anyone help a couple of weeks ago i was having a prob with my 90 sc it back fired and i lost power an would not start again so i talked to sum people on here and they told me it sounded like my harmonic balancer broke well come to find out sure enough it snapped in half so i took it all apart got a new balencer and put it back together now it still wont start i have spark fuel and air checked the injectors and they seem to be working fine now i dont no what to do can any one help again

92sclikenew
03-05-2010, 11:33 PM
can anyone help a couple of weeks ago i was having a prob with my 90 sc it back fired and i lost power an would not start again so i talked to sum people on here and they told me it sounded like my harmonic balancer broke well come to find out sure enough it snapped in half so i took it all apart got a new balencer and put it back together now it still wont start i have spark fuel and air checked the injectors and they seem to be working fine now i dont no what to do can any one help again

did you pull the plugs are they wet with fuel?

pickel69
03-05-2010, 11:37 PM
yes they r

pickel69
03-05-2010, 11:48 PM
also when i crank it thats all it does no poppin or n e thing can n e one help please as of rite now its my only means of tranportation just totaled my truck a couple days ago

pickel69
03-06-2010, 01:13 AM
can n e one help with this iv read some other forums but still have no answere

the-big-e
03-06-2010, 01:15 AM
What kind of balancer did you replace it with (stock or BHJ)

It sounds to me like the balancer isn't on all the way......

pickel69
03-06-2010, 01:29 AM
yes iy is stock replacement matched up to the old one before installing also it seemed to be on all the way torqued to spec met up with crank sensor ok

decipha
03-06-2010, 02:10 AM
is the check engine light and up-shift light going out when your cranking? if not then the crank sensor is faulty

how do you know your getting fuel just because the pump primes doesn't mean the injectors are spraying? how did you check the injectors?

there's an inertia switch in the trunk on the driver side, make sure that didn't get tripped when your car backfired... i've had that happen on a backfire :p

you did use a balancer press when putting the new balancer on correct? you didn't just beat it on and tighten the bolt correct?

pull one of the plug wires off the coil pack and just let it rest where its suppose to go, get someone to crank it and see if its getting spark

if your truly getting fuel and spark then your idle air control valve is either unhooked or you have a serious vac leak

pickel69
03-06-2010, 11:41 AM
up shift light has never worked since ive owned the car not sure about the engine light i checked the injectors with a meter did not beat the balancer on i pressed it on and torqued to spec i have good spark at the plug i pulled wire and plug to check

Motohead
03-06-2010, 11:41 AM
is the check engine light and up-shift light going out when your cranking? if not then the crank sensor is faulty

This one gets my vote as the broken ballancer likely took out the crank sensor