PDA

View Full Version : Nice site cover picture



mcate
07-05-2010, 09:59 AM
That pic was taken in 2004 at the Mustang Club of Tidewater show, right around the corner from my old house in Chesapeake!

95_XR7
07-05-2010, 10:20 AM
Honestly, it's one of my favorite pictures of the car. I had e-mailed them a few new pictures, but they really didn't do the car justice.

And 2004? Heck, that was before I even owned the previous SC. :eek:

-Corey

nickleman60
07-05-2010, 10:39 AM
Supercoupe of the month and you haven't ever laid eyes on the car.........:p

Corey, you won't be dissapointed when you finally get to see it in person.

z90sc
07-05-2010, 11:39 AM
.......thought that car looked familier....
z

Roadhawg
07-05-2010, 12:44 PM
.......thought that car looked famalier....
z

There was a guy that use to live in Chesapeake, that had a Thunderbird Supercoupe which looked a lot lie that one.

z90sc
07-05-2010, 10:35 PM
There was a guy that use to live in Chesapeake, that had a Thunderbird Supercoupe which looked a lot lie that one.

.....yup,I remember that guy..I was there the day that pretty black SC almost fell on his head :eek:........
z

mcate
07-05-2010, 10:48 PM
Good memory! Wasn't when we were installing the shift kit?

Roadhawg
07-06-2010, 06:49 AM
.....yup,I remember that guy..I was there the day that pretty black SC almost fell on his head :eek:........
z

I think he was a lawn mower salesman. Didn't he move to Ohio so he could sell farm equipment or start a manure farm?

z90sc
07-06-2010, 11:58 AM
Good memory! Wasn't when we were installing the shift kit?

....yep,2 drive on ramps and 1 rear jackstand ='s possible disaster....but we "got'er done"....lol.....and he was "spreading manure" before he left :D
z

mcate
07-06-2010, 06:59 PM
I remember how when it shifted into O/D it was like it was in neutral. Couldn't figure it out, & then I had to get underway for 10 days. Got back home & still couldn't figure it out. Then had to get U/W again for a week. Did a lot of searching online while at sea & found an article on TCCoA about that dreaded O/D servo piston. Finally fixed it when I got home!