PDA

View Full Version : mount removal in progress!!! pic



anlo
10-11-2010, 07:52 PM
well im deep into mount replacement ==going top front route so far no issues got two of the mount to block bolts out not even tight about to jack up car and motor for the thru bolt. upper and lower tubes and i/c are pretty dirty /brown gummy i know how to get those clean but wondering what to clean the s/c top and rotor area???? pic included.once you get the accy bracket and ic tube out of the way the s/c engine aint so intimidating!! having fun taking my time lots of breaks working well.. changing water pump as well for insurance..dont have p/s pully puller so im bummed about not trashing that stupid bracket may still do it though..

main question:: how to clean up s/c top and visible rotor area safely????

motor raised all bolts to frame off mount wont just slide out of course so will i need to remove bracket thru bolt and separate before removing ? maybe raise motor more?

got it had to remove lower tube support bracket two pieces classic failure..

Tim Groth
10-11-2010, 09:06 PM
The oil residue is normal and leaving it on the rotors is what I would suggest. No need to make extra work for yourself.

-Tim

shoalcracker
10-11-2010, 10:31 PM
You may have to rmove the plenum.

Not sure if you'll get enough lift on motor before hitting cowl/firewall.

Paul

anlo
10-12-2010, 12:53 PM
drivers side went well no issues i placed the hearter hose with the silicone on the bracket tab so far text book mount change.. waiting on the water pump to come in before putting back together.. while waiting on water pump could i just go ahead and switch out transmission mount ?? or wait till passenger side is complete?

anlo
10-13-2010, 03:11 PM
all mounts done water pump replaced tubes and top sealed what a job but not as bad as i anticipated... passenger side the knock sensor and guard had to come out..... and had to drop starter for installation room all done from bottom.. nice feeling
havent road tested yet need a nap..