PDA

View Full Version : Need help with 1992 seatbelt and chime problem



90turbo1
11-14-2010, 12:47 AM
So I spent about an hour this morning looking at wires in doors and such, drivers side passive restraint is in rear most position and doesnt move (thank god) but pass side works fine.

here is the other problem i have. when you drive the car there are no door ajar lights on, no seat belt lights on, and it doesnt ding at you to connect seat belt. everything is quiet. but... when you turn the headlamps on the car starts dinging at you constantly till you shut the lights off, (even though the car is running).

any ideas?

thanks

90turbo1
11-14-2010, 08:07 PM
no one?

?????

the-big-e
11-14-2010, 08:31 PM
Your restraint problem is most likely the front A pillar limit switch.....

There is a cover for the restraint motor near the edge of the rear seat bottom....

Turn the knob on top of the motor until you get the belt clip to move a few inches, then see if it moves when you close the door....

90turbo1
11-15-2010, 04:43 PM
COOL, i will try that tonite.

any idea why the chime starts going off all the time when the car is running and headlamps are on???

so if the limit switch is the culprit what is the fix. is that built inot the seatblet assemlbly?

thanks again

the-big-e
11-15-2010, 05:45 PM
I have no idea why the chimes come on with the headlights.....

Maybe a bad wire or headlight switch.....

You can replace the limit switch....

You will have to remove the A pillar trim cover....

Use a small flat screwdriver to pop the limit switch out, then disconnect it from the harness.....

90turbo1
12-04-2010, 03:18 PM
I have no idea why the chimes come on with the headlights.....

Maybe a bad wire or headlight switch.....

You can replace the limit switch....

You will have to remove the A pillar trim cover....

Use a small flat screwdriver to pop the limit switch out, then disconnect it from the harness.....

so tried to move the seatbelt using the twist knob on the motor. it moves about 2 inches then is impossible to turn so I can turn it back to rear lock then when door is open now the seatbelt jumps but doesnt move. so is the track or motor bad?

I have been reading threads about swapping to later normal seatbelts, in my b pillar there are steel inserts but are not threaded. is that where the seatblets attach? do I just thread the steel insert or do I need a nut on the backside?

thanks

92sclikenew
12-04-2010, 03:40 PM
so tried to move the seatbelt using the twist knob on the motor. it moves about 2 inches then is impossible to turn so I can turn it back to rear lock then when door is open now the seatbelt jumps but doesnt move. so is the track or motor bad?

I have been reading threads about swapping to later normal seatbelts, in my b pillar there are steel inserts but are not threaded. is that where the seatblets attach? do I just thread the steel insert or do I need a nut on the backside?

thanks

when i have trouble with my pass seat belt its always the latch switch..

at least once a month i have to soak my latchs with pb blaster or they will quit working till i mess around with it..

could be your issue..

also sounds like your track is getting binded up.. when i had to manualy move my belt i had to pull on the latch at the track and turn the knob on the motor.

mines also a 92 tho i doubt that matters.

90turbo1
12-04-2010, 03:46 PM
yes, tried helping the latch at same time and no go.

can a person still buy that track or is it junk yard only parts now.

92sclikenew
12-04-2010, 04:03 PM
yes, tried helping the latch at same time and no go.

can a person still buy that track or is it junk yard only parts now.

well it could be the door latch switch is what i was talking about at first..

does the door ajar light stay on?

90turbo1
12-04-2010, 04:06 PM
no door ajar light goes out when the door is closed. so does the dome light so both switches are working.

it seems to me that the track is blocked or something. like I said I cannot more the latch using the manual method at all, only a few inches then it stops.

92sclikenew
12-04-2010, 04:12 PM
no door ajar light goes out when the door is closed. so does the dome light so both switches are working.

it seems to me that the track is blocked or something. like I said I cannot more the latch using the manual method at all, only a few inches then it stops.

can you get it to move back forward?

90turbo1
12-04-2010, 04:15 PM
the latch is in the rear most position, I can get it to move forward about 2 inches then backwards again to the rear most position again. it will not move further than that no matter what I try.

the-big-e
12-04-2010, 05:27 PM
I would replace the entire assembly....

I'll bet the plastic track holder connector has broke....:mad:

When this happens, the track will spool out into the space behind the sail panel....

I've seen two of them like this in the past few months.....

hawgy
12-04-2010, 05:45 PM
the plastic track is like a belt when it comes off it makes the seatbelt motor run longer then it should. as far as the chiming the module is behind the glove box on the right side unhook it and see what happens http://www.sccoa.com/forums/showthread.php?t=61689 its labeled #2 in the pic. its the 4th post down

90turbo1
12-06-2010, 10:56 PM
I would replace the entire assembly....

I'll bet the plastic track holder connector has broke....:mad:

When this happens, the track will spool out into the space behind the sail panel....

I've seen two of them like this in the past few months.....

i guess I will hit the yards this weekend.

thanks i will let you know when I switch then track out.