PDA

View Full Version : #2 cylinder dead



slick59
03-08-2011, 10:00 PM
The 90 I just bought has been sitting for 4 years. changed starter and got it started, Idled rough and had no power when in gear would hardly move the car. Started pulling injector plugs and found that #2 cylinder was dead. Compression check was 35#:(. Will tear the head off this weekend. What is the most common problem with these engines? No valve noise no knocking. Just wanting to get an idea of what I'm getting into.

RalphP
03-08-2011, 10:10 PM
Blown head gaskets.

RwP

Chrismiss
03-08-2011, 10:37 PM
make sure you get all the old fuel out of there. Been down that road recently.

Have injectors flowed and cleaned while they are off.

slick59
03-15-2011, 08:46 AM
Got the heads off, Intake valve is warped on #2 and #3. Going to have all new valve installed.

slowpoke
03-15-2011, 09:44 AM
slow down just a min. these valves dont typically warp for no reason. can you see why it warped. is there any damage on anything else?

slick59
03-15-2011, 11:55 AM
The guy I bought it off of blew the Head gaskets, rebuilt the bottom end but did nothing with the heads. couldn't get it to run right and there it sat for 5 years. I'm sure he sucked in water got steam and warped valves. Heads look good, seats in the head look good as well.

slick59
03-27-2011, 08:59 PM
Well,

Just got the bird started again. It started right up but idles like crap and when i crack the throttle it pops and backfires???? Timing issue??? I didnt touch anything rebuilding the upper end that affected timing.

Ideas/comments plz

Tim

rzimmerl
03-28-2011, 11:29 AM
Shouldn't have an issue with timing if you didn't remove the cam synchro. I'd lean towards the injector plugs are on correctly and the same for the plug wires, and/or vacuum leaks.

David Neibert
03-28-2011, 12:51 PM
Double check that the plug wires are on the correct cylinder per this chart. Some repair manuals had the coil pack cylinder numbers printed wrong.

http://members.tccoa.com/dneibert/PlugandWireLayout.jpg

David

slowpoke
03-28-2011, 01:32 PM
who did you have work on your heads?

slick59
03-28-2011, 10:01 PM
Thank you David, you nailed it. My book is different than the diagram you gave me. So car started and ran great for 5 minutes then it slowed and died. Tried to start it again, heard a pop and it started. went out under the hood and no supercharger movement, belt broke. Son of a ------. Supercharger is locked up tighter than a drum wont move. Just rebuilt the damn thing. I love these cars it just wont stop. Its kinda like the terminator SARA CONNOR???

David Neibert
03-28-2011, 11:11 PM
Thank you David, you nailed it. My book is different than the diagram you gave me. So car started and ran great for 5 minutes then it slowed and died. Tried to start it again, heard a pop and it started. went out under the hood and no supercharger movement, belt broke. Son of a ------. Supercharger is locked up tighter than a drum wont move. Just rebuilt the damn thing. I love these cars it just wont stop. Its kinda like the terminator SARA CONNOR???

Glad that helped, now just find yourself another supercharger and when you bolt it down, check to make sure it still spins freely. I've seen some that required a little shimming between the supercharger case and manifold at one of the rear bolts to keep it from binding when torqued down. Sounds like that may have been the case with yours.

David

decipha
03-28-2011, 11:18 PM
I've seen some that required a little shimming between the supercharger case and manifold at one of the rear bolts to keep it from binding when torqued down.


:( i think i need to check mine