PDA

View Full Version : new here!



wiSC
02-21-2012, 09:56 PM
been lurking here for a while. i have a v6 mustang 5-speed with a 89 super coupe 5-speed motor. just joining to get some suggestions on different go fast goodies!

wooby94
02-21-2012, 10:45 PM
Welcome to the club! You'll learn alot here

SuperCoupe007
02-23-2012, 03:36 PM
Welcome to the club. Well its hard to say what mods since the SC motor is in ur Mustang, and we don't know what mods you have done already. BUT exhaust is always the first place you want to start. Second you might want to add a 5% OD pulley to the SC or you can do the 5% JackShaft pulley. One other suggestion is to post in the 'technical' or 'non-technical' sections. You will get much more exposure out there

wiSC
02-23-2012, 11:07 PM
Welcome to the club. Well its hard to say what mods since the SC motor is in ur Mustang, and we don't know what mods you have done already. BUT exhaust is always the first place you want to start. Second you might want to add a 5% OD pulley to the SC or you can do the 5% JackShaft pulley. One other suggestion is to post in the 'technical' or 'non-technical' sections. You will get much more exposure out there

Right now I am running basically a bone stock 89-93 setup. I have the Mustang's stock "tubular exhaust manifolds" and true dual 2.25" exhaust and a CAI. I think I really need a FMIC before I get an OD pulley. Hopefully this spring I can figure out a FMIC setup on the car. Right now, the tiny stock intercooler sitting behind my Mustang radiator really isn't doing a very good job.

SuperCoupe007
02-26-2012, 03:30 AM
A FMI is understandeable, specially if you IC is sitting behind the radiator. So have you taken her to the track? Share some pics whenever you can.

94SCguy321
03-04-2012, 06:13 PM
i got a 94 tbird sc and its givin me some problems with oil spraying out of the dipstick tube i cant for the life of me figure out why

SuperCoupe007
03-04-2012, 07:02 PM
94SCguy321::: I have heard of that symptom before. If I remember correctly I think it was from one of the old so-cal members that had your symptom after a rebuild. If i get a chance this week, i'll ask around around.

NOTE: You can also post your this question on the "Technical Forum" and you might get lots of help. Oh yeah, try the "Search" function as well. I like the search as you will get asnwers quickly :)

:)