PDA

View Full Version : 1990 SC Anniversary Edition, Ontario Canada



Extreme1ont
05-27-2012, 02:01 AM
New here from Ontario Canada.

1990 Anniversary Edition.

My dad just got this car, was going to scrap it. he buys and sells and scraps cars, he got it dirt cheap. i hate to see it get scrapped so im going to buy it from him. had a 92 a few months ago too that was rotted out and was sent for scrap but it did run.

This car was 1 owner, babbied its whole life, always serviced regular. had just spent over $2000 in new parts and all serviced, then it through the harmonic balancer for the 2nd time and was parked for 2 years, lost storage for it and had to sell it.

So the balancer is still broke off. going in the next few days to see if the other car my dad scrapped a while ago is still at the wreckers to get parts. everything appears to work on the car all lights, windows ect.
With the balancer not on will it start without the crank sensor ??
I had it rolling over today but wont fire, has old crap fuel in it too could be part of the issue, have to press the brake pedal so it will crank im not sure if theres something else needed to do for it to fire, it has the factory security/alarm in it and not sure how to De-activate it.

Im not much of a ford fan, i own and mod 2 chevy beretta's 88base v6 5 speed and 96 z26 auto. those are my babbies, but this super coupe is way too cool and need a new toy to play with and want to get it back to tip top shape and make it spotless.

Ill be around here alot asking dumb questions LOL and showing off my new project.

Theres in the box, head light and tail light GTO covers and bug deflector, box of goodies in the trunk with 3 or 4 coil packs, ignition modules ect.

Whats some simple mods to get some extra ponies out of this? i know the pulley can be changed, dual exhaust and some aftermarket converters would help im sure, is there anything that can be done tuning wise or chip the ecm ?

First thing i guess is to get it running, the last SC my dad had we spent half a day cranking it before we got it to fire and run, i guess once these things sit for a while they can be a bugger to get running again.


http://i919.photobucket.com/albums/ad35/extreme1ont/IMG630.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG631.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG642.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG641.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG633.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG617.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG613.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG647.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG612.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG611.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG609.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG607.jpg

SuperCoupe007
05-27-2012, 03:57 AM
Congratulations on your new SC :)

I would recommend that you post your questions in the "technical forum" this would get you much more help to getting answers and help to getting her back and running in the road.

Once you get her running, you are going to INSTANTLY fall in love with the supercharger. It is instant POWER!

Welcome and enjoy the load of help you will get form the fellow SC'ers :cool:

A1cntrler
05-27-2012, 01:08 PM
I do not recognize the close up of the "Anniversary Edition" badge you have shown there. Where is that located on the car?

For that many miles on it, the paint looks to be in decent shape. Also is missing the factory radio, and not sure what that is in place of the CD player.

Good luck! Enjoy the Annie!

Extreme1ont
05-27-2012, 01:19 PM
I do not recognize the close up of the "Anniversary Edition" badge you have shown there. Where is that located on the car?

For that many miles on it, the paint looks to be in decent shape. Also is missing the factory radio, and not sure what that is in place of the CD player.

Good luck! Enjoy the Annie!

the badge is on the front in the center. i think the one on the door panels have the Anniversary on them too, and the rear one between the lights.

The anniversary edition had the leather with suede seats, and all were painted black with the silver on the bottom, so im pretty sure its genuine.

Its in KM not miles. so its around 101,000 Miles, thats nothing really for its age.

A1cntrler
05-27-2012, 01:24 PM
I have 2 Annies, one with 123k miles on it, and the other with 96k miles on it. I know where the badges are at and what they look like. What I meant was that I have never seen that badge before. It may be something custom that was added at one point.

I see when I look closer that it is in kilometers now. Silly Canadians. :D

Extreme1ont
05-27-2012, 01:52 PM
I have 2 Annies, one with 123k miles on it, and the other with 96k miles on it. I know where the badges are at and what they look like. What I meant was that I have never seen that badge before. It may be something custom that was added at one point.

I see when I look closer that it is in kilometers now. Silly Canadians. :D

hmm im not sure about the badge then.. all i have is the few pictures, the car isnt here its still at my dads so i cant just run out side and look at it lol.

Extreme1ont
05-29-2012, 12:16 AM
the badge is on the front, under where the hood closes.. theres another on the rear just below the trunk lock on the trunk. on the door panels as well say anniversary edition.

Also the tag under the hood on the rad support says 35th.

The anniversary edition was 3,731 built.. this should mean there is a build number for each car ?
How do you know what number you have ? 1-3,731

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG657.jpg


.......... #0 322 ???

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG661.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG676.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG664.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG666.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG667.jpg

never smoked in....
http://i919.photobucket.com/albums/ad35/extreme1ont/IMG671.jpg

http://i919.photobucket.com/albums/ad35/extreme1ont/IMG675.jpg


......

also why doesnt this thing have a factory spoiler ? was that an option ?

A1cntrler
05-29-2012, 01:03 AM
The spoiler was an option. As for those emblems in the front center and rear center: They are not stock and were added at some point in the cars life.

As for build number: They were not tracked. I think the number you have there is correct for the number built, but the breakdown between 5 speeds and autos I do not think has ever been confirmed (Popular rumor is 147 of those are 5 speeds.)

Here is a link to more info about the Annie: http://www.35thatr.org/


Try the 0322 on your keypad at the door...see what that does for you.

ALS35
05-31-2012, 03:18 PM
To answer one of your original questions ... the car will definitely NOT start without the balancer on there. The crank sensor target ring is on the balancer.
Good to see you are saving an Anni. With a little TLC that one will clean up and look pretty good. I drove mine year round in Toronto for 13 years and the tinworm turned it to dust. It had 454,000 km on the clock when I sent it for scrap. Lots of transplanted parts in other members cars keep her spirit alive.
Alan