PDA

View Full Version : Fuse Problem? Lighter and Locks not working



Seuss
01-09-2013, 02:22 PM
I plugged my cell phone charger in a few weeks ago and the radio speakers, lighter, and power locks all stopped working. I checked the fuse box and it indicated the one of the metal grey ones (3 on 1 side of the box) controlled the locks and lighter. I swapped them around, but nothing in the one for the lighter/locks worked and they all worked for the windows.

Any ideas? Should I check all the other fuses? My SC is a 1989.

RalphP
01-09-2013, 10:18 PM
I plugged my cell phone charger in a few weeks ago and the radio speakers, lighter, and power locks all stopped working. I checked the fuse box and it indicated the one of the metal grey ones (3 on 1 side of the box) controlled the locks and lighter. I swapped them around, but nothing in the one for the lighter/locks worked and they all worked for the windows.

Any ideas? Should I check all the other fuses? My SC is a 1989.

Did you check both fuse boxes - the underhood and the underdash?

Also, I'd be checking the EVTM and seeing if they're on a common leg off the ignition switch.

RwP

Seuss
01-10-2013, 01:32 AM
I just checked under the dash...forgot there was another under the hood. I will check that one too, thanks!

Seuss
02-10-2013, 09:39 PM
I completely forgot to update, but it was the fuse box fuse in the engine compartment. I thought that was odd, considering almost everything in the other fuse box worked. Ah well, hopefully this will help someone else if they encounter the same problem :)