PDA

View Full Version : Front end noise! Help



shocar4
01-14-2013, 05:41 PM
Okay so I pull in to church yesterday and get this awful scrubbing noise coming from my front end....sounds like a ball joint maybe.....come home and take the wheels off and I can get no play from anything.....drive to work today and all seems okay, until I am in the parking lot at slow speed I hear the noise again as I turn....sounds like mainly the driver side....came home to inspect and with the car on cement and turning the wheels, it is scretching from both sides.....thought maybe my rack....but the ps fluid looks great and is full....my upper control arms look rough, so I am going to replace them tomorrow.....has anyone else has this experience.....also when I break hard it has this weird pull to the right which I have never had before either..

I spend 4 hours sat washing, claying and buffing and this is how she repays me:)

sdw
01-15-2013, 12:23 PM
You have worn strut rod bushings. If it is pulling they may well be missing.

You will need an alignment after they are replaced.

Make sure they are torqued down properly or you will be doing it again sooner rather than later. When the boneheads at Fountain Tire did mine they didn't and they were chewed up within the week.

Sean

shocar4
01-15-2013, 09:20 PM
Ok well went out this afternoon and did some work.....replaced upper control arms and both end links.....strut rod bushings look fairly new (still nice and blue)....lower ball joints look really bad, going to change them this coming weekend....oh and I also cut 1 full coil off each spring to begin my drop.
Took it down the road and no noises at all....fingers are crossed