PDA

View Full Version : stock bottom end vs. 4.2 stroker bottom end... input please



TOOFAST87
11-24-2013, 09:23 PM
stock bottom end vs. 4.2 stroker bottom end... input please HP tq. Strength. Torque range. I have 10% SC pulley. Gasket matched Ported & polished heads manifolds inlet and outlet for SC and TBopening matched. Arp studs Scorpion roller rockers Factory headers. Ported and outlet opened to 1.950" with 3" exhaust system with xpipe and borlas. Was running. 18psi before all this. Then blew hgs so did all this stuff. Now after done its only running 5-7psi. Now it spun a rod bearing. So much for the Arp rod bolts I put on. Didn't have a problem before. Anyway. I'm either going to get factory bottom end fixed or stroke it. Either way will also receive a jackshaft pulley kit to get boost back. And recommendations or input would be appreciated. Thanks

XR7 Dave
11-25-2013, 09:17 AM
Sounds like you have a variety of problems. It wasn't the rod bolts that cost you the bottom end, most likely it was a boost leak that washed down cylinder walls and thinned the oil. But that's just a guess.

The stock 4.2L has very skinny powdered metal rods so I wouldn't trust it with much boost. It will run fine as along as the tune is right (clearly your tune isn't right so keep that in mind) up to about 300rwhp. Beyond that you will have no margin due to weak internal parts.

If the SC is 89-93 then you will also have a problem with mounting the crankshaft sensor on the 4.2L block. You'll also need different (read more expensive) head studs on the 4.2L block. To properly stroke an SC motor you need custom pistons and longer rods.

TOOFAST87
11-26-2013, 11:35 AM
Its stock šomputer. No tune. 89 5 speed car. I putting 4.2 bottom end in SC block. if it'll work be got a 4.2 motor. Anyway I pulled motor when it blew hgs because previous owner had drove it with bad mounts which rubbed hole in pan from kmember. So while I had pan off I put new rod and main bearings and Arp bolts. Ran great before no noise from bottom end everything was original Ford parts at 187k but minus hgs still looked good. After I got motor back in it made a rattle like spark knocking at top of third gear in a hard pull. And on ran 5psi. But still ran same speed from point to point so I posted about it on here everyone was saying it's probably spark knock and low boost due to the extra flow from porting and big open exhaust. Eventually it spun a Rod bearing and can hear piston slapping head. Only thing I know I need is cooling fan controller. I have toggle switch hooked up because it still got hot found that fans weren't working. Can't find a controller for it. Please lend me your expertise. Should I stay with SC bottom end and just have crank and rods fixed. To be able to drive it to work I had to run 50 weight Lucas racing oil. Got rid of rattle so i drove it I think the thick oil caused the bearing to spin from possible lack of lube not sure. In the long run and low budget I have it'll cost same at engine shop to fix my sc crank and rods as they want to put 4.2. Stuff in. Thanks

XR7 Dave
11-26-2013, 11:46 AM
There are too many issues with what you posted above to the point that I don't know where to begin. :o

Jacob_Royer
11-26-2013, 11:58 AM
Get a new motor start over!!