PDA

View Full Version : 93 5-speed



pock1
05-25-2015, 01:50 AM
i just picked up a 93 sc 5-speed yesterday. battery was dead, so i put a jump on it.still no start. i hear a suttle : click: . ok so im thinking the battry was dead (and it was took a full day to charge). put the battery in no start same faint click sound..hmmmmmm maybe starter or the relay on the side near the battery. it's been awile since i had a stick sc. i was going to try n jump the silnoid.( take off the trigger wire, and by pass it by taking a screwdriver and touching 2 of the ignition trigger and power to bump the starter. it;s been awile since i had to start from scatch lol.

MadMikeyL
05-25-2015, 07:58 AM
If the battery was completely dead, then just charging it may not be enough, you may have to replace it. I would start by swapping the battery out for the one in your other SC and see if it starts. If it doesn't, try jumping the solenoid with a screwdriver. If it still won't start then with a known good battery and jumping the solenoid, then it is likely a bad starter. If jumping the solenoid starts it, but it won't start on the key, then it is likely something in the wiring from the ignition switch to the solenoid.

pock1
05-25-2015, 01:13 PM
If the battery was completely dead, then just charging it may not be enough, you may have to replace it. I would start by swapping the battery out for the one in your other SC and see if it starts. If it doesn't, try jumping the solenoid with a screwdriver. If it still won't start then with a known good battery and jumping the solenoid, then it is likely a bad starter. If jumping the solenoid starts it, but it won't start on the key, then it is likely something in the wiring from the ignition switch to the solenoid.

hey miley yeah that;s what i was thinking. i;ll get on it asoon as i get back in town. thx.

pock1
05-27-2015, 08:10 PM
well I found out why no start.........u jumped the solenoid and car started. runs really ruff, wants to stall. some im thinking the .....iac valve is clogged.the other problem is.........the key is not starting the car.........ignition switch is bad. there is no alarm or fuel cut off switch.