PDA

View Full Version : Where does this plug go on '94 SC?



nickleman60
09-12-2015, 12:30 PM
Where does this plug go? I'm having a brain fart and can't figure it out...........:confused: I have no dash lighting so I'm guessing it's for that but I can't find the female connection around the master cylinder where the EVTM manual says the plug for dash lighting is......or am I completely on the wrong path?

decipha
09-12-2015, 01:12 PM
If memory serves that connector isn't used on the 94-95, I could be wrong

nickleman60
09-12-2015, 04:46 PM
You're probably right and it never was plugged in. After more searching what I don't have working are the od off light and no alternator voltage. ( I switched to a LX gauge since I have an aftermarket boost/vacuum gauge ) All of my 5 aftermarket gauges, 3 in the pillar pod and 2 in the radio location don't have power neither, they're all suppose to power up when the ignition is turned on. I've been checking fuses and I've found no bad ones yet. I know it's something stupidly simple and I'll find it eventually.

I found the problem, it was just a blown fuse under the dash............I must have missed it the first time looking..............:o

z90sc
09-13-2015, 02:17 PM
....you got that beast rolling yet ?

nickleman60
09-13-2015, 07:55 PM
....you got that beast rolling yet ?

Yes........so far so good...;)

David Neibert
09-15-2015, 10:53 AM
Yes........so far so good...;)

Keith,

Can't remember if I already asked, but are you coming to Shootout this year ? Would really like to see you and see your car on the track with the 2.3 Whipple upgrade.

David

DrFishbone
09-15-2015, 12:28 PM
Keith,

Can't remember if I already asked, but are you coming to Shootout this year ? Would really like to see you and see your car on the track with the 2.3 Whipple upgrade.

David

Me too! :)