PDA

View Full Version : 4.6L V8 P0302 OBD2 code - ideas?



potshotscott
09-13-2015, 04:30 PM
Okay - so I picked up a 4.6L 94 LX so that I can put my SC in the garage for the winter. It had a CEL when I bought it. Probed it for codes and came up with misfire #2 cylinder. So far I've replaced the coil pack with a spare, flipped #2 and #8 cylinder plug wires, replaced all spark plugs and even replaced the #2 plug wire. Reset the PCM after each item and the CEL came back.

Today I decided to flip the #2 fuel injector with an injector from #4 cylinder. Reset PCM and the same P0302 code came back. There's fuel getting to #2 cylinder since #4 didn't misfire AND the #2 plug is wetter than the rest of the plugs. Is it possible that the #2 cylinder injector stays open more often than it should? The reason I ask that is that the car idles a little choppy but the car runs REALLY well at high speed/high RPM.

Next thoughts/steps for me include testing the wiring to #2 injector along with checking the recommended items in the OBD2 diagnostic routines in my Ford factory manuals. Anyone have any deeper experience with this along with some possible suggestions?

racecougar
09-13-2015, 05:04 PM
It's quite possible, as hung injector drivers are a known issue with the aging '94-95 4.6L EEC's. Stick a noid light on there and you'll see right away whether it's pulsing or holding the injector open.

potshotscott
09-13-2015, 05:43 PM
I have made a discovery (I don't have a noid light). I have learned that while I have each injector harness off the car the control lines have infinite resistance (open) from the control pin to ground. The #2 cylinder shows ~800 Ohms. When I remove the PCM connector from the PCM (open the circuit) I have infinite resistance. That means the white wire from pin 101 is good and is not shorted. It would seem as though I have a faulty PCM. Sad panda - at least they're cheap at my local pick and pull yard.

potshotscott
09-14-2015, 03:05 PM
Follow-up to close out this thread and perhaps for someone's information in the future.

The misfire in #2 cylinder was indeed caused by the PCM. I took my PCM apart last night and metered from pin 101 (the #2 injector signal) to pin 103 (the ground pin) and the resistance was still 800 Ohms right in the computer itself. Went to my local wrecker, found a "AD" PCM that is compatible with my "AE" PCM. Swapped the AD in and the car runs like a dream!

Thanks for the nudge/help racecougar!

racecougar
09-14-2015, 05:42 PM
Great to hear you've got it solved!

FrankenBird
09-15-2015, 08:16 AM
I would have never guessed the pcm, good job man !
lol, my dad had been trying to fix his lp fireplace for 4 years, even had the company come over twice and try and they couldn't fix it. I looked at it for 5 min and found the on/off switch was bad...lol alllll the work they did and it was something that simple.. moral of the story is just keep tracing down the problem and start with simple things befor you go on it the hard way.

racecougar
09-15-2015, 08:40 AM
It's a relatively common issue with the '94-95 4.6L EEC's.