PDA

View Full Version : My 1995 SC work-in-progress



warmaster259
10-07-2015, 09:42 AM
Hey guys,

Picked up a bone stock Pearl White 95 SC automatic to add to the flock. Cars body is great, engine seems strong except for some bad sensors, transmission is what I'm unsure about. When I went to buy the car the mlps was obviously messed up. Car would accelerate forward in neutral, reverse did not work at all. Drive worked and shifted through it's gears normally. I purchased and installed a new mlps(neutral marks aligned) and changed transmission fluid with 12qts of Mercon V.

Now the transmission works perfectly in Park, Neutral, and reverse but when I put it in drive I have to accelerate to about 3000rpm to get the car moving. Second gear is the same way, when it gets to third it feels like the torque converter locks up and then I'm able to accelerate up to normal speeds. If anyone could offer some insight to what may be going on I would really appreciate it.

I've pulled the KOEO codes but not sure if I am translating them correctly. Here is a link to the video of my test. https://m.youtube.com/watch?v=3ojqJQceiuk

MadMikeyL
10-07-2015, 12:59 PM
Are you 100% sure the fluid level is full?

warmaster259
10-07-2015, 08:37 PM
Yes, 100% on fluid level. The one code I seem to be getting references the Transmission temperature sensor. Would this have any effect on my issue?

MadMikeyL
10-07-2015, 09:32 PM
It certainly shouldn't cause the symptoms you are experiencing. If anything, that would send it into failsafe mode and it would default to 2nd gear, but you said it is shifting through the gears, so that rules that out. Does it behave the same regardless of whether the shifter itself is in D, 2, or 1? If it works properly in the manual settings but not in D, then it might be that the shifter itself is misaligned. I have seen that before where D is actually between D and N on the shifter, and if you put it in D, it will want to neutral out, but in those cases, selecting the gear manually made it engage normally.

warmaster259
10-07-2015, 10:33 PM
It will manually shift throught the gears but with the same symtoms getting going

warmaster259
10-13-2015, 09:58 AM
In the process of swapping to a 99 mustang trans now.

warmaster259
10-23-2015, 08:48 PM
She's back on the road running good! Now going through all the miscellaneous crap. Door sagging, endlinks shot, radio not working, etc.