PDA

View Full Version : knock knock?



Thrty5thSC
11-20-2002, 03:28 PM
my car just started somthing new.slight knock only in the morning
when its bone cold, thenit stops when it's warm.this makes me mad! this is my 3rd engine in 2 yrs! not even 4000 mi. yet!
anyone had this knock problem?do you think it's the bearings?
maybe a falty oil pump?any suggestions would be great.
thankyou
joe

BadBird90
11-21-2002, 12:28 AM
Yeah i was pretty much experiencing the same thing and here is what i did: First i changed plugs and wires, then i changed oil and used 20w-50 for 2000 miles, then i replaced motor mounts to the solid rubber ones, b/c the old motor mounts were shot, and were coming apart, and lastly i got the most primium gas i could get, and put some fuel system cleaner in the gas, if you are gonna try this make sure you get the complete fuel system cleaner and not just the injector cleaner. I heard this somewhere but i think the real reason why my engine was knocking was that the motor mounts were torn soo bad that metal was hitting metal and was interfereing with the knock sensor, and that would cause the knock sensor to send bad messages to the computer causing the engine to knock. i doubt it is your oil pump or bearings i bet it just needs some kind of matinence that needs to be done to it. hope this helps. How many miles is on your car?

Thrty5thSC
11-21-2002, 01:17 AM
178,000mi. but the engine almost 4000. 8000 on the supercharger . i know my mounts are bad,i should know better.last time my mounts broke, my engine fell on the frame, and cacked my oil pan. my plugs and wires are new, but i'm going to try the 20-50 and fuel system cleaner.
thanks bro.
joe