PDA

View Full Version : 90 sc drivers side oxygen sensor connector location



thekidz
05-22-2017, 04:48 PM
Hi all I hope you can help. Last year at the end of season a mechanic friend of mine replaced the head gaskets on my 90 sc. I just got the car out of storage and it was pulling codes for a lean condition. I took a chance and bought new oxygen sensors. I replaced the passenger side no problems. When I got to the drivers side I found it wasn't plugged in. I have just spent the last 3 hours trying to find the connector. Does anybody have an idea of the connector location or the harness that it comes out of? I am at my wits end trying to find it. Any help would be greatly appreciated.

Thanx in advance
Craig

thekidz
05-22-2017, 08:25 PM
Uggggh. 6 hrs later, and I still can't find the @&$&__ connector lol. I guess I'm going to have to start taking more of the top of the engine apart. Any suggestions would be appreciated

Thanx
Craig

potshotscott
05-22-2017, 08:32 PM
On my 94 they're up underneath and near the exhaust (of course). Take the existing one and stretch the wire all the way out then think about how/where it would fit. One has to think that the connector is within reach of the sensor harness.

thekidz
05-22-2017, 08:54 PM
Lol, that's what I thought. All I can think now is that when the head gaskets were done, the harness must have gotten moved. Up on the hoist looking up, down on the hoist looking down. I think I'm going to need to remove the sc intake plenum to try and get a better look from the top. It would be really nice to know what part of the wiring harness it is in. Anybody?

Thanx
Craig

KMT
05-22-2017, 08:59 PM
This is a shot of a '95, so....is it where the arrow points?
67185

Back of the head, near/in front of the rear of the block near where it mates to the trans, I think. Looks to be on the harness that goes to the ACT sensor, so if you can follow it down, maybe.

I tried following it by hand from up top on my '90, but didn't get farther than back of the head...might be held there w/a bracket - not sure.

Good luck.

Ken

thekidz
05-22-2017, 09:26 PM
That's where I thought it should be. I just checked the wiring diagram and it looks like it shares a header plug wiith the act, water temp and oil sender. I'm going to take off the intake plenum to try and get a better view from the top because I can't see or feel it from the bottom. Thanx for the help.