PDA

View Full Version : Problem:Car is revving up when put in park.



Nkuk35
08-15-2017, 04:52 PM
So just today my 1990 cougar xr7 has started to rev up from normal idle to 2500 to 3000 rpm when i put it in park. I also don"t have to give it any throttle from 0-35mph. Can anybody tell me what is wrong. I looked to see if the car has a TPS Sensor and when i looked up A TPS Sensor on the Auto zone and Advanced Auto Parts websites nothing came. Does that mean the car is drive by cable. Please let me know what is going on and how to fix it.

TbirdSCFan
08-15-2017, 05:13 PM
Your IAC is likely to blame. Its the assembly straddling the throttle plate that controls the amount of bypass air and hence the idle speed. You need a new one.

David Neibert
08-15-2017, 05:15 PM
I agree that it sounds like the IAC valve. When you shut it off does it make a sound that sounds like a honking goose is under the hood ?

David

TSC89
08-15-2017, 05:46 PM
TPS and IAC locations.

TSC89
08-15-2017, 05:48 PM
Parts on RockAuto.com

I used a 1990 Thunderbird SC as the car but the parts are the same for both.

IAC

http://www.rockauto.com/en/catalog/ford,1990,thunderbird,3.8l+232cid+v6+supercharged, 1140387,fuel+&+air,idle+air+control+(iac)+valve,6072

TPS:

http://www.rockauto.com/en/catalog/ford,1990,thunderbird,3.8l+232cid+v6+supercharged, 1140387,fuel+&+air,throttle+position+sensor+(tps),5136

Nkuk35
08-15-2017, 06:17 PM
I agree that it sounds like the IAC valve. When you shut it off does it make a sound that sounds like a honking goose is under the hood ?

David

Yes it does sound like a goose honking under the hood when I turn it off

Nkuk35
08-15-2017, 06:20 PM
Thanks for the help guys I will probably replace both just to be safe.

DrFishbone
08-16-2017, 12:04 PM
Thanks for the help guys I will probably replace both just to be safe.

You'd probably better off with an original Motorcraft TPS that still works over an aftermarket new one.

The IAC will take care of the problem. ;)

David Neibert
08-16-2017, 01:04 PM
You'd probably better off with an original Motorcraft TPS that still works over an aftermarket new one.

The IAC will take care of the problem. ;)

I agree...I've seen several of the aftermarket ones that didn't work properly. You can usually pick up a good used one for $15 to $20 in the classified forum.

David

89SCfan
08-16-2017, 05:18 PM
Check out this thread. This one works well for me.

http://www.sccoa.com/forums/showthread.php?136212-Alternative-IAC-to-Motorcraft-part-works-great

Nkuk35
08-24-2017, 06:44 AM
replaced the TPS sensor waiting for the IAC Valve. I received and email last night from partsgeek.com that they don't have the part in stock. Just a waiting game now.