PDA

View Full Version : Instrument cluster



RS2600
01-16-2020, 12:49 PM
Will an instrument cluster from a 89 SC work in a 91 without issues?

KMT
01-16-2020, 09:21 PM
I've swapped '91 & '92 clusters into my '90. Mixed and matched gauges too.

Might be different fuel gauge anti-slosh daughter boards from one year to the next...not sure it matters, but if you spot something wonky about the fuel gauge/low-fuel light circuits, you may need to swap them out and keep the one that came with the car in play. It is a small printed circuit board that sits on one end and slots into it's socket from the rear, as I recall.

Ken

RS2600
01-17-2020, 05:19 AM
Problem is , my fuel gauge stopped working after I took the cluster out, needle now points way out to the right.
Dont know if I shortcutted it somehow.

KMT
01-17-2020, 11:50 AM
Ouch - EVTM says this about that:

'Fuel gauge indicator always reads 'E', doesn't reach full or is pegged full.
- Defective anti-slosh or Check Gauge module -- replace anti-slosh board or check gauge module
- Inoperative fuel gauge -- replace gauge

Funny we're talking about the fuel gauge, tho. I had to replace the gears in my speedo head a few months ago, and next time I bought fuel my fuel gauge didn't want to swing full range. Took me a while to notice since i don't drive it much this time of year. I opened the cluster and found that the tail of the needle on the fuel gauge was broken off/dangling and dragging the needle against the inner bezel. I swapped in another fuel/boost gauge and problem solved. I may have cracked that needle in the past, and it was ok/hanging on until the last time I took the cluster apart.

The EVTM has testing procedures for the gauge and sender circuits, I'll try to summarize. Empty, the sender should read 14~18 ohms; full 154 ~ 162 ohms. Gauge should reach empty or below with a sender resistance of 15 ohms, and full or above with a sender resistance of 160 ohms. If gauge does not reach empty or full, replace gauge.

If the guage just complained with no other repairs going on, I'd wonder about the wiring at the pump in the tank, and/or that circuit in general, but since your issue seems related to messing with the cluster, I'd focus efforts there. Know how to swap out the fuel/vacuum ~boost gauge pair?

RS2600
01-17-2020, 05:29 PM
I'll check with my EVTM as soon as it arrives to see if it has any suggestions