PDA

View Full Version : bad running



Charkly
04-24-2003, 09:23 PM
Ok-after dealing with flooding problems-and finally getting my car running good-i decided to put on headers, cl 76mm mass air, 10% blower od, change the sc seal, and put new wires, plugs, and 02s in. When i fired it up after everything was done-it wouldnt idle-it had a nasty skip to it, and had to run at 4k rpms to avoid stalling until it warmed up. once its warm it idles ok-but when you drive it it skips and sputters and bucks. The electronics for the mass air are brand new-the plugs are all burning near white-and the firing order is correct-whats wrong with my car guys-help me please! Almost Every single sensor in the car is new-all but the tps, iac, and cam and crank sensors-any ideas would be great-e-mail has changed-MikeOefelein@hotmail.com thanks.

scbird1
04-24-2003, 10:19 PM
Im not sure on this but the mass air sensor needs to be set up with a chip.

Thrty5thSC
04-24-2003, 10:28 PM
check your firing order. even the best can mix a wire or two up.
joe

Charkly
04-24-2003, 11:56 PM
I checked the firing order 500x-I even went to multiple manuals as one was incorrect-I called ford and super coupe performance, and the firing order is verified to be correct. As for setting up the maf-what does that mean-i just put the new electronics on the c&l-i have red 30# injectors, and the sampling tube is yellow.

rivlee
04-25-2003, 12:10 AM
I would suggest better plug wires and the plug gap should be set to about 45.

Thrty5thSC
04-25-2003, 12:16 AM
i'm not sure about the colors but if you have 30 lb injectors your maf should be calibrated for them. i don't think you would have the problems you have though. i would try a new cam sensor check everything again to make sure everything is plugged in. were in upstate are you, maybe i am close and could come look at it. i could bring my friends snap on scanner if your not to far away, i'm in syracuse.
joe

Charkly
04-25-2003, 12:29 AM
Im in Burlington Flats Ny-Syracuse is about 1.5 hrs from me. It would be awesome if you could come see the bitch. I hooked up a snap on scanner and it said nothing was wrong-Thanks a lot.

Thrty5thSC
04-25-2003, 12:37 AM
e-mail me your address and maybe i can come this weekend. i'm not driving my sc yet because i need shims for my new auburn diff.
i wouldn't mind helping a fellow sc'er out.
joe