PDA

View Full Version : light ticking/clicking when accelerating



ChrisPearl95
05-19-2003, 10:25 AM
I hear this when getting onto the throttle, no acceleration problems, just hear this sound. Vacuum leak?

Thanks.

Chris :confused:

Randy N Connie
05-19-2003, 11:29 AM
Do you mean like a clicking sound of a lifter?

Will the clicking sound go up & down with the RPMs?

ChrisPearl95
05-19-2003, 11:35 AM
it goes up with rpm's, but when I stop accelerating or have cruise control on, it does not occur. Not sure about lifters at all.

Thanks

Chris

Aaron Pedroza
05-19-2003, 11:51 AM
Sounds like an exhaust leak, if it is it will get worse the more you drive it.

ChrisPearl95
05-19-2003, 11:56 AM
Had a slight exhaust leak after it was installed last fall, that was fixed...this is a different sound.

Thanks.

AsScLoWn
05-19-2003, 03:11 PM
if its a flapping sort of noise your SC top might not be sealed properly, look for oily spots around where the top meets the blower

WestCoastGhost
05-21-2003, 04:23 PM
Started running Redline 20-50 and it stopped. Dirty lifter?? Or maybe excessive lifter/valve stem wear???

Randy N Connie
05-21-2003, 07:27 PM
WestcoastGhost.
If that was it ,you should have a smoother idel with out a bubbleing sound on start up.

rlong
05-23-2003, 12:47 AM
i would think exhaust leak up at y pipe where it hooks on to manifold or egr transducer hose melted or vacuum leak

cudaz101
05-23-2003, 02:20 AM
It may or may not be...But I had a ticking/pinging though it was a lifter at first, then thought it was the knock sensor cuz it seemed to only happen uner Acceleration...So...Anyway I am thinking it is not a huge issue cuz the car behaved fine otherwise...

Well it it took a turn for the worse and ended up being a pretty loud knock one day...I pulled the eng. and it turned ou to be a mainbearing...This was a ~~~ ford reman eng. though...

I hope that it is something small....

Brad