PDA

View Full Version : need help



daivd z
06-09-2003, 11:39 PM
i just bought my 95 sc 5 speed with 55K on it. the temp guage usualy stays right about straight up. but if im idling for a while it will go up and the fan will kick in. is it normal for it to stick straight up (between m-a) also after running my car a little hard i shut if off for a few min and when i started it back up it had a really rough idle and the motor was shaking all over. it hasnt done it again yet. also the 5 speed is really hard to get into gear and second is tough to get into. are there any short shifters made for the sc? thanks for info

Digitalchaos
06-10-2003, 12:41 AM
Hello, and welcome. It is perfectly normal for your gauge to reach just past the M in NORM before your low speed fan kicks in, then drop back to about between the R & M. This is especially true when traveling slowly in warm weather or in traffic.

As for the stuttering you noticed, this is most likely what many notice after shutting the engine down for a little bit then restarting it. It is widely believed to be either vapor lock or leaky injectors, and somtimes occurs when the engine is restarted warm, especially on warm days. Other than the abnormal idle, this isn't really harmful. Try running some Barryman's fuel cleaner through & see if that doesn't help.

As for the shifting difficulties, your clutch may be starting to wear down. I believe these symptoms are sometimes attributed to the throwout bearing. If the trans doesn't grind when shifting, have the clutch looked at. A bad clutch can lead to bad synchros, which is something you want to avoid. You can also try having the clutch hydralic system flushed & refilled, with either DOT 3 or 4.

Lastly, there are shifter rebuild kits available for the SC. It is likely that one of them would suit your needs. Others can recommend these.

Hope that helps..

daivd z
06-10-2003, 12:52 AM
it was around 90 degrees today and i was starting it with the engine warm again. it idles fine the rest of the time. the clutch only has 55K on it and the guy that had it before me said he never rode the clutch or droped it at high rpm's. it sometimes grinds when trying to put it in gear when the pedal is on the floor. and sometimes i have to really push it into first with the pedal on the floor. this is my first 5 speed RWD car and it makes soem clunking noises when i shift someitmes is that just the way they are?

Digitalchaos
06-10-2003, 01:36 AM
For the most part these noises are not normal, and could be attributed to multiple things. First, the grinding is likely your 1st-2nd gear synchro.. but it could be the clutch causing most of it. The clunking you're hearing could also be the throwout bearing.. depending on when you are hearing it.

If the previous owner of that car was also the original owner, he was not completely honest with you. This is not very suprising, as these cars lend themselves to abuse do to their sportlike nature. Unfortunatley I think there where those who bought them new and decided they were Mustangs, rather than exceptional personal luxury cars. In any case, the things you mention come from dropping or sidestepping the clutch at higher RPMs, speed shifting, and power shifting. I would have a competent mechanic check the clutch out for you, and as a start have it flushed. This could be the main factor for your problems.

Good luck..

daivd z
06-10-2003, 01:17 PM
thanks for the info i will look into this.

rlong
06-11-2003, 12:51 AM
mine makes some clunking noise when shifting ever since i got it over 150k ago i think its just play in the rear end in mine ill run it till it goes i dont even hear it im used to it my friends always say whats that noise but its not really that bad its just free play in the rear gears on mine but i do see other members saying their rear bushings go bad and i think that would be a lot louder noise,, my temp guage with 180 runs below n if im in traffic it goes to almost halfway then fan kicks on it never goes much above halfway then when i get moving it goes right back down below n

daivd z
06-11-2003, 12:24 PM
it could be loose gears. when ever i push in the clutch when shifting it makes a clunk noise like the drive shaft just fell out or somehting and sometimes when im rolling about 3-5 mph comming to s stop i will have my foot on the clutch and try to put it into 1st but it wont go and sometimes make the same noise as when shifting but all im not shifting im just trying to put it into first. also it doesnt seem to have the problems of not going into gear when the car is not running. do you think my through out bearing is going out?