PDA

View Full Version : Psm Bird



fastasu
06-20-2003, 12:11 AM
Hey Guys,
90SC 100K miles
my car is acting goofy. It runs great , then the tach goes dead a the car starts cutting out ,the car shutters, like it's running on maybe 3 cylinders. I pull over turn the key off, start it and it runs fine , but no tach though. then the tach will start working again. It runs great. A few more miles then the same thing happens. Now sometimes it won't start unles I turn the key off and retry 3 or 4 times. Ok here's what I've norrowed it down to. I replaced the DIS module, still does it. Someone suggested the EEC-IV module..Where the #@&^$%#$^% is that at, I looked inside both kick panels , not there. I think I need a new EEC-IV because my book says that 's probably it with TROUBLE codes etc, but I don't want to spend $200.00 on something I may not need.....HELP

tbird88
06-20-2003, 01:14 AM
What codes are you getting? Sounds like the coilpack is acting up. The EEC is up inside the passenger kick panel (leave it alone).

'bird

racecougar
06-20-2003, 01:19 AM
This really sounds like the cam sensor (aka Cylinder Identification sensor or CID sensor). Have you pulled the codes? I'm assuming that the check engine light comes on, right? The EEC's (computer) usually don't go bad, and it would be a pretty rare occurence for the EEC to cause the problems you described.

By the way, the EEC is located behind the passenger side kickpanel, trust me it's there. Remove the kickpanel and the insulation behind it, then look up in there. You'll see a large black plastic rectangular connector with around 60 wires going into the side of it and a 10mm bolt head in the middle of it. That's the connector that plugs into the EEC. That info is just for future reference though, you shouldn't need to pull your EEC at this time.

Have Autozone read the codes for you, or buy a code reader and do it yourself, if you haven't already. Let us know what the codes are.

-Rod

rivlee
06-20-2003, 01:26 AM
Mine did exactly the same thing when the Cam sensor went bad.

Lee

3tbird
06-20-2003, 01:43 AM
I had the same problem, Dealer said computer I said what were the codes, (I know own a code scanner) and told them to replace sensor.

Mine was the result of a leaking blower snout seal (I bought the car with the seal problem) Original owner thought the issue was the DIS.

Oil got into the CID (thing that is were a distributor use to be). You may want to pull the 2 hold down screws and gently clean out oil, dust, etc... and see if that helps. Also check for a cracked cap.

fastasu
06-22-2003, 04:14 PM
Big Giant Thank You
HI FABULOUS THUDERBIRDS. I JUST WANTED TO THANK ALL OF YOU THAT HELPED ME WITH MY 90 PMS SC. IT WAS THE CAM SENSOR THAT CAUSED IT TO RUMBLE BUMBLE AND STUMBLE.

NOW IT JUST SMOKES THE TIRES AND FLIES, OF COURSE YOUR NOT FLYING WHEN THE TIRES LOOK LIKE COTTON CANDY BUT AFTER THEY HOOKUP..............