PDA

View Full Version : Power Steering Question



07-16-2003, 02:36 PM
Hey guys,

I just got to ask, how long would it take to replace the pump, rack and pinion, and hoses? My power steering went out a week ago, and holy crap, i have to say, im not a big guy, and im struggling to turn the wheel. My buddy was calling me a woman until he tried to drive it. anyway, yeah, the fluid was gushing everywhere, i thought it was oil, i was getting ready to beat my friends *** cause he borrowed it to get some paperwork filled out and everything...

ok...question is how long would it take to replace everything associated with power steering? could i just kiss my saturday goodbye?

thanks in advance
stephen

LJGriggs
07-16-2003, 03:23 PM
If your mounts are shot, the engine has probably dropped onto the P/S line at the frame causing a break. This is not that uncommon. If your mounts haven't been replaced, do that first. You may be able to get away with just replacing the lines. (thats what I did when mine went out about 4 years ago...)

07-16-2003, 04:37 PM
i havent been able to get the time to look under the car to see if it just a line or even look at it period. what are some tell tale signs of motor mounts being bad? i know the search button works, and i will use it, but like how far should everything be away from each other? motor to body wise? i did read that someone had bad mounts and the oil pan had a hole wore into it by the motor moving around as a result...

LJGriggs
07-16-2003, 05:22 PM
There are several ways to tell....you can have someone put the car in gear with the engine running, press hard on the brake, and give the engine a quick rev... If the engine jumps more than an inch, the mounts are shot. Also, if you can't get the oil filter off because of the crossmember being in the way... the mounts are shot. If the car has never had new mounts, or if they were replaced with OEM hydraulic (jelly donut) mounts more than three or four years ago, they are shot.

In general, unless you have solid rubber mounts, they are (or soon will be) shot.

07-16-2003, 06:06 PM
thanks man...i dont have that much of a problem with the oil filter, now...or then, when i last changed my oil. Ill check on saturday when i change my oil. so it could be something as simple as just changing a line, sweet.:D

--edit--

now that i think about it...ive never changed motor mounts, what would it entail? what do i need to take off in order to get to them? im pretty sure all i would have to do is loosen the tranny mount, hook a cherry picker to the motor, unbolt the motor mounts, pick the motor up a bit, put in the new mounts, then take the cherry picker off, tighten the tranny mount and be good, right? or am i mistaken?