PDA

View Full Version : Brakes Locking up



IGot6UGot8
07-20-2003, 09:48 PM
I just got an '89 SC with 110K on it. As I was driving it home, I had to stop rather quickly at a light, and the brakes locked up. I looked at all the brakes and they seem fine, so I took it out and locked them up a couple more times. Only the fronts are locking, and I'm getting no brake or ABS lights coming on. Does anyone know what I should look at next? BTW... the car sat for a couple years without being driven.

Thanks
Jake

TbirdSCFan
07-20-2003, 10:18 PM
Look for missing fuses; look for the antilock light tom come on and go off when you first start the car. Look at the ABS power relay if the light doesn't come on. Then, lastly, you might have an original ABS accumulator which is on its way out.

Mike8675309
07-20-2003, 11:59 PM
Do you notice if you feel any brake assist? It sounds like the hydraulic pump isn't presurizing the system. But you should get lights with that.

So first make sure the guy that sold you the car didn't disable the dash lights to hide that fact from you.

When you first start the car, all idiot lights should light up to let you verify the circuits are working. Make sure you see the ABS and Brake light. If not, then likely you have one problem (no abs hydraulic pump) with multiple possible causes.

J57ltr
07-21-2003, 01:28 AM
I concur.

Dash lights would be my first guess too. Did you buy it at a car lot?

Jeff

IGot6UGot8
07-21-2003, 01:58 AM
I got if from a guy that didn't know a whole lot about them. He drove it for a couple years, until the fan motor froze up and fried the fusible link. Fixed the motor, but never replace the "wire" that goes to it. I'm pretty sure all the lights come on when the key is on. Sometimes, when I lock them up, they'll lock, let go, then lock again. Other times they'll just lock up. Also, it's just the fronts that are locking, not the rears.

Jake