PDA

View Full Version : exploding waterpump



quick35th
07-23-2003, 01:25 AM
ok so it didn't quite explode, but something sure did let go inside the waterpump. There was fluid leaking from the underside of the pump as if the shaft from the inside shot threw the bottom of the pump(that would explain why I heard noises like stuff was coming out and hitting the ground). I have few questions that I hope I can get answered, because I planned on going to the Supercoupeperformance open house this weakend. First, should I just go to a place like Advanced Autoparts to buy the pump or can I buy a performance one? Also how hard is it to replace? And finally I thought I read here once before that I dont need to put the brace between the waterpump and the powersteering pump back? Is this true that if I dont put it back on it wont hirt anything? Any help is greatly appretiated since I also had planned to go to the Brickyard 400 the fallowing weekend too!!

Thanks!!
Shane
Check out my car and tell me what you think!
http://www.goodhumorracing.com/ovr/2003_pe4/pages/OVR%234%20024.html

J57ltr
07-23-2003, 01:34 AM
There aren't any performance water pumps available. Buy what you feel comfortable with.

There is a hole in all water pumps it's called a weep hole. It is there to tell you that the pump is bad. What happens is that water makes it's way past the bearing seal and bearing and into the chamber between the front and rear bearing.

If Ford didn't think it was needed they wouldn't put it there. Companies don't spend money on structural parts because they think they'll look pretty, there is a reason it is there.

Jeff

Kurt K
07-23-2003, 08:38 AM
... I dont need to put the brace between the waterpump and the powersteering pump back? I'm sure Ford says it's needed (and it probably is), but after installation and removal several times in the past year, I left it off this time. I know several guys that don't have the bracket installed any more.

quick35th
07-23-2003, 04:18 PM
Thanks guys for all of your help!

Shane

quick35th
07-24-2003, 03:29 PM
The verdict is in now on what hapenned to my water pump. Yesterday when I was taking it apart I discovered that the front bearings had blown out! Then when I took the rest of the pump off, the rear bearings were sucked in! I hope it didn't cause any problems internally.

Thanks!
Shane

J57ltr
07-24-2003, 03:55 PM
Only to the water pump.:D

AsScLoWn
07-24-2003, 10:09 PM
Originally posted by quick35th
The verdict is in now on what hapenned to my water pump. Yesterday when I was taking it apart I discovered that the front bearings had blown out! Then when I took the rest of the pump off, the rear bearings were sucked in! I hope it didn't cause any problems internally.

Thanks!
Shane

yea you grind the heck out of the water pump, I'll bet you 50 bucks you have a metal film floating under radiator cap:D . I've only ruined 3? pumps in 30,000kms so far:cool:

white90sc
07-25-2003, 10:20 AM
3 pumps are you ill? well i would hate to see you change a tire ASSclown?? nice name

:rolleyes: :rolleyes: :rolleyes: :rolleyes: