PDA

View Full Version : Update on sunroof not stopping at close



Michael Mattix
07-24-2003, 08:13 AM
Just wanted to update a thread that I posted a while ago with a problem of closing my sunroof. It would go to the vent and open (all the way back) positions, but it would not stop at the closed position. I went to my Helms manual and found out about the synchronization that has to be done when you install a new sunroof motor, so I tried that and it worked! So, if anyone has this problem, I would try this synchronization procedures first. Then replace the motor if necessary. Unfortunately for me, I bought a new (used) one already which, now I don't need. But, one thing I can't figure out, is what caused it to get "out of synchronization"? Oh well, as long as she's working again!

Mike

stocker 89
07-24-2003, 10:00 AM
Do you hear a click. That is when you should let off the switch. Then it is where it is supposed to be . These are not very good seals on these cars. It is get as close to metal as you can. It could have been better. AH, these cars have GREAT paint jobs on them even if they do leak a little no big deal.

kamakazie_1
07-24-2003, 10:56 AM
Usually replacing the motor and not following the Sync procedure is what gets them out of sync to start with... Mine was doing the same thing and it was the Sync procedure that corrected the problem.. I have the moonroof portion of the 90 factory manual scanned and in PDF format it you want it.

RJ

Michael Mattix
07-25-2003, 08:57 AM
Maybe I didn't make myself as clear as I could have. My sunroof would close, but the switch wouldn't do it automatically. I had to do the synchronization procedure.

stocker 89
I hope the above answered your reply. My sunroof didn't leak, it just stopped working automatically with the switch in the closed position.

kamakazie_1
Thanks for the offer, but I have a hard copy of the Helms manual already. That's the only place where I found the synchronization procedures, which lead me to believe that the sunroof (for some reason) got out of synch on it's own. It was a crazy thing as far as I can figure out, because it just started happening one day. I am a licensed aircraft mechanic, so I do have some maintenance background, which usually helps lead me in a direction of "what did I do to it last". Using that analogy usually points right to the problem. But, with my sunroof, it just got out of synch. No real explanation.

kamakazie_1
07-25-2003, 11:43 AM
Huh, that's wierd, like I said I'd seen that same problem with no explination... Three of them through a lot of research from past owners finally proved out to be, they took their car to an idiot in the past and they had changed the Sunroof motor, it was on one of the guys invoices, he didn't even remember it being done. Just happened to send me everything they had done on their cars that they had invoices for. That's the only way I found out about the change.

Don't know that I've ever seen it happen just cause, but hey it's electrical, ya never know...

RJ

stocker 89
07-25-2003, 03:38 PM
YEAH. I got all **** from the start SUNroof ( what the heck is that). I thought we were talking about a moon roof.

kamakazie_1
07-25-2003, 04:29 PM
Originally posted by stocker 89
YEAH. I got all **** from the start SUNroof ( what the heck is that). I thought we were talking about a moon roof.

Moonroof / Sunroof, who cares the hole in the roof that opens and closes!! :D :D

SuperCoupeSC91
07-25-2003, 11:58 PM
i have this same problem in my SC, ever since i bought a new sunroof from some guy in Canada, i put it in (not the motor, but i may have disconnected the motor in the process) and it doesnt stop at the inbetween point (where its closed), mine just keeps going... what is the correct way to fix this ? this is cool i never thought of looking into it ? also how do you clear out the Sunroof drain tubes i know mine are clogged, i just gutted moslty alot of my interior panels and i tried to pull the drain tubes out but no luck, i tried to follow them down to where they go on the buttom no luck...should i take an air hose to the tubes to clear them out ? any tips ? Thanks Alex Lachance

*Important Tip*
(Installing sunroof/moonroof)
Please dont make the mistake i did, (i was so angry and it was a waste of time) i assumed you had to take out the inner roof liner and all the panels inside to replace the sunroof....ahhh was i PISSED when i saw there was no way of doing it from the inside when i dropped the roof panel after i took out all the panels..

kamakazie_1
07-26-2003, 12:39 AM
Hey Alex, I have a PDF file of the procedure but it's at the office, I can't send here from the house with this lousy dial up connection and hotmail.. I'll double check the thread on Monday and see if someone else answered you yet, if not I'll send you the file from there.

As far as the drains.. I used a stainless whip antenna on my first set of plugged drains... Worked OK.. When I got my 35th last year the passenger side was plugged and like you said couldn't get it out of the rocker to save my life. I finally figured out what it was.. The factory has spray in insulation in the lower kick panel to direct the water that might get in there to the drain holes in the seam of the rocker.. In the case of my 35th I couldn't clear them, was hitting something really hard to no avail with the antenna, I tried air, nothing, so then I got to looking the factory must have sprayed the foam in and then shoved the drain line done there in the kick panel, the lower 3 inches of the drain was full and hard of that spray foam and the line it's self was sealed good and tight in the rocker with the foam also. I ended up using a small screwdriver around the outside of the line till I could dig it loose from the foam and then clean the line itself out and replaced the line in the new bigger hole I created with the screwdriver and reloaded the panel with a light load of the spray foam from home depot..

Check for foam it might be the problem..

RJ

Kube
07-26-2003, 01:53 AM
My sun roof has had this issue ever since I bought the car! I always wondered why it did not stop at the closed position! Is it a simple procedure to sync it?

Michael Mattix
07-28-2003, 08:22 AM
Yes, it's pretty simple. If you want the actual procedures, I think I could bring my Helms manual in and send you a copy of it, but it's more simple that you would think.

1. Put the sunroof/moonroof nearest to the "closed" position as you can get it.

2. Open the access panel (it pulls down from the forward part and is hinged in the back), and make sure you pull on it from towards the front of the access panel.

3. (If you take a look at it now, the cam that has a notch in it, probably does not align with the microswitch, which this is why you are having a problem, mine was. This procedure will fix that. My microswitch was blue.) Take the two bolts out that hold the motor assembly to the top of the car.

4. Remove the motor from the spline and let it hang from the power wires.

5. Make sure the ignition switch is in the right position to have power to the sunroof and then toggle the sunroof/moonroof switch (I used the "open" side of the switch, not the "vent" side, I don't know if it really matters and the procedures didn't have anything on it) until you hear it stop (the cam is notched over the microswitch).

6. Install the sunroof motor assembly and give it a try, it should work fine now.

7. Reinstall the access panel.

Like I have said, my SC is a 95 with 76k and I have never messed with the motor assembly. Which is why I don't know why it could have gotten "out of synch", but oh well, it works good now! Now I've only got to level the glass with the body. Mine kinda sticks up in the front.

MTTod
07-28-2003, 09:43 AM
Crap, I must be stupid or something. I've read about the "access panel" everywhere and still can't figure out where it is or how to get to it! I've got the Ford manual and the picture in there looks like something my kids drew.

Do you pull the headliner out first or what's the deal here? My MR motor is shot and I need to replace it.

Michael Mattix
07-28-2003, 04:01 PM
Sit in your backseats and look straight up! I have an extra motor if you'd be interested. Like I said before, I ordered it thinking that I needed it, but alas, all I had to do is resynchronize!

MTTod
07-28-2003, 06:50 PM
Ok then my car is wierd cause there ain't nothin there but headliner material. Maybe someone redid the headliner in mine and did it wrong?

On my 90 the headliner goes under the trim panels around the 1/4 windows. Also there's a thicker padded part that runs across the back above the rear window. That goes in under the side trim panels too.

I know where the motor is but there isn't any way to get to it without pulling the side panels and the headliner.

Michael Mattix
07-29-2003, 08:00 AM
Well, it looks like someone replaced the headliner with one out of a SC without a moonroof and just cut a hole for the opening. Well, it sounds like to me that they didn't cut the hole for the motor access. You might want to search on the for sale boards to find an access plate and the cut a hole for yours. You might want to find an existing headliner to get some exact measurements.

victor malvar
06-30-2004, 01:22 AM
I posted the reply twice! Any help with my other post is most welcome! Everyone have a great Day!

victor malvar
06-30-2004, 01:26 AM
Hi Alex, Michel, everyone, I am having to re-wire the moon roof on my Sons SC....Any help here would also be very appreciated as well. We got the motor to work today! The vent opened or (the rear of the roof) but the front does not open at all Or is it supposed to? I should say, I was getting ready to intall a perfect stock Moon/Sun roof, then found out that mine is an aftermarket :mad: The motor is good we tore all the head lining off, so any help with the headlining would also be very helpfull. Any adjustments in the motor or anyplace else would help us have this done ASAP. My Son will arrive on July 3rd 2004 from the Military He has been deployed for two years strait as a Chinook pilot! I want to have his SC ready for him, as coming home gift. Hey Alex call me! Thanks to any and all that can help me out :D :confused: The Best to all!
Victor

Mike8675309
06-30-2004, 09:02 AM
Here is a wiring diagram for the motor and the switch for a 1993.

Digitalchaos
07-09-2004, 07:13 PM
I have recently been performing work to my sunroof and now also need to align the stopping position. However, when I went to remove the screws for the motor I found they were extremely tight.

There does not appear to be any corrosion, and the heads are in good shape. I purchased a new screwdriver as the old one had wear which was increasing difficulty, but I still can not budge them.

Has anyone experienced this, and perhaps might offer a solution?

Thanks!

Mike8675309
07-09-2004, 11:55 PM
When I pulled a motor out of a car in the salvage yard I also found them very tight. When I got them out it looked like Red loc-tite was on the threads. I have screw drivers with hex sections on them. I think I pushed hard with the screwdriver and then used an adjustable wrench to turn the screwdriver.

Digitalchaos
07-11-2004, 12:19 PM
Thanks Mike. I figured there would be loctite on them :rolleyes: lol. I have already used a channel locks to turn the driver to no avail. The new screwdriver I used was an $0.88 Stanley from Walmart, of very low quality. It also seems slightly too small.

I think I will try purchasing another from a hardware store that is slightly bigger & higher quality.

I wonder if I can spray penetrating oil around the heads and expect it to reach the screw threads?

Nate93
12-21-2004, 12:36 AM
So what exactly IS the synch proceedure? I'll need to do that if I ever get my sunroof to close. It's stuck to the rear currently. Happened on my way to my honeymoon, go figure :)

Thanks,
Nate

Mike8675309
12-21-2004, 12:50 AM
Uh, Michael included it in this thread near the top.