PDA

View Full Version : electrical problems



danekejt
07-28-2003, 12:22 PM
this morning driving into work some wierd things where happening with the car:

1) when i applied the brakes my radio would turn off and back on
2) when i applied the brakes my tach would jump up.
3) also noticed that my anti lock brakes light came on and did not go off. didnt notice any other litghts that came on and stayed on.

i got to work and turned the car off. when i tried to start it nothing happened at all. car was completely dead and getting no juice.

i am thinking it is one of 3 things

1) need to clean the connections at the battery
2) bad battery
3) bad alternator.

Let me know what you guys think. thanks

LJGriggs
07-28-2003, 01:57 PM
My first thought would be the ignition switch. Seems like most electrical gremlins have their source at the switch. Ford did a recall on the ignition switch several years back. You may want to have a Ford dealership run your VIN number through their service department's computer system to see if the repair notice was ever completed (if it applied). In the mean time, try jiggling the key in the switch to see if it will make contact.

MIKE 38sc
07-28-2003, 03:18 PM
Yes that would be the first place I would look.

danekejt
07-28-2003, 03:25 PM
i had that problem with another 91sc that i had. i put in another steering colum that had the another ignition on it and that did the trick.

for this problem at lunch time i went out and tried to start the car and it was completely dead. i cleaned the battery posts and cables and the car started right up. so i am going to clean them up better tonight with the the battery post cleaning tool and apply some white grease.

thanks for all the suggestions. appreciate it.