PDA

View Full Version : Cooling system on fritz??



BobGPz
08-17-2003, 10:49 PM
Hey guys,....question for cooling system pro's here...
I have a '90 5-speed with 120,500 miles. Only mods worth mentioning here have been white face guages, SCP exhaust from end of stock manifolds out to the back, removed air silencer and am using the SCP/K&N intake system (K&N is NOT getting cool air down the hole where original was). Car will get to normal temperature quickly and stay there for few minutes. Then it will climb rapidly with short and few shots of the throttle and/or boost. Guage gets all the way over to the other side in short time. This is after I tried a new thermostat and gasket; new sending unit for guage, hoses, radiator flush, etc. It did this LONG BEFORE the replacement of the guage faces, so I count that out. I rarely see the overflow dump fluid as I keep a watchful eye on guage, but it has overflowed before. I am running around town with air conditioning on to force my fan to kick on, which DOES help lots! However it seems like they are not kicking on correctly or soon enough.

My question is,
1. Could the ECT Sensor be bad? How do I test?
2. What is this ICRM thing by passenger headlight, everyone talks about, do to control fan/s? Can I test it? I have voltmeter. I'd rather fix problem than cut #14 wires.
3. Radiator plugged and needs to be replaced?
4. K&N drawing hot air from engine compartment making it overheat?

MIKE 38sc
08-17-2003, 10:55 PM
Probably a combination of 3 and 4, but more 3 than 4.

BobGPz
08-17-2003, 11:00 PM
Huh?
#5 was take it out to the woods and shoot it, but I never posted that. Are you psyhcic Mike?

OK, so #3 & #4 then?

MIKE 38sc
08-17-2003, 11:08 PM
Yes 3 and 4. But I did know that there was a 5th step. Theres always that last alternative, we just dont always talk about it!
Kinda spoooky isnt it? LOL!