PDA

View Full Version : !/4 tank stalling



Ty Whutaker
10-20-2003, 08:43 PM
i just bought an sc. really pleased so fart, but today, at 1/4 tang it acted like it was out of gas. i limped to a station and, sure enough the car ran fine aftert i added some. i believe the level float and pump are on the same mechanism so i am guessing it is out of calibration. my question is, what else could it be? it almost seemed like a throttle position sensor for awhile. any help is appreciated.
ty

pastera
10-21-2003, 06:16 AM
Sounds like a bad sending unit - had one in my 87 Feiro and just made the best of it because its not worth dropping the gas tank for a minor annoyance. If you know that 1/4 tank is acutally empty, just plan for it.

Aaron

fordified
11-01-2003, 08:20 AM
My 89 bird will do the same thing at a half tank. I know that the sender is alright. It seems to be more of a problem in the summer while its warm outside. I can usually get down to a quarter tank once the temp outside drops below sixty. Ive replace the filter and checked fuel press. The stall dosn't have to happen at any particular time either. (ex hard acceleration or just hyw crusing). It almost feels like a electrical stall but the problem instantly goes away once the tank is full. Anyone else have this problem??

SC UL8R1990
11-01-2003, 09:12 AM
could be vapor lock? .....or look into a new fuel pump.

darriantbird
11-03-2003, 09:42 AM
I had the same problem with my old turbo coupe,well what it was is the pick up on my fuel pump broke off from a loose baffle in the gas tank banging around. take off your gas tank and look your gonna have to evetually any how to find the problem!

darren139
11-04-2003, 06:43 PM
I agree with darriantbird mine broke in my 90 5.0 mustang and it banged around with the gas it also shorted wires on pump the wires started burning a bit. I dont like the idea of things burning in fuel tank. maybe get it looked at
:p