PDA

View Full Version : my tach twitches....



darkstar_one
12-20-2003, 03:24 PM
hey... well sometimes on the freeway... im cruising at around 2000 rpms and my tach will twitch... it will just fall down about a centimeter and go back up to its normal position... dont know what it is... also... when i shift into nuetral... the TACH WILL go down to IDLE RPMS and then just start twitching up and down up and down .... it scares me so i just shift back into Drive. anyone have a clue?

quick35th
12-20-2003, 03:39 PM
When The tack "twitches" is it just the tach needle that is moving or does the rpm of the engine twitch too? If it is just the tach that is moving than the reason could be the starter relay. Its on the driver side fender near the battery. Make sure that there isn't any wires coming in contact with any other wires as this could cause your problem.

Shane

J57ltr
12-20-2003, 03:49 PM
Originally posted by quick35th
When The tack "twitches" is it just the tach needle that is moving or does the rpm of the engine twitch too? If it is just the tach that is moving than the reason could be the starter relay. Its on the driver side fender near the battery. Make sure that there isn't any wires coming in contact with any other wires as this could cause your problem.

Shane

Care to explain?



It couold be the cam sensor or a bad tach. Do you have problems starting it sometimes?

quick35th
12-20-2003, 04:52 PM
Originally posted by J57ltr
Care to explain?


Well it was happening on my neibors friend's 5.0 slowstang. When the wires would touch the tach would "twitch." The solution was to move the wires around so that they wont come in contact with each other again. This was also a problem in question with my old 5.0 but it turned out to be the computer.

Thanks!
Shane