PDA

View Full Version : Suspension creak noise when turning ?



Ariz02
05-13-2004, 09:34 PM
in the frontend on pass.side in the area of the wheel. Seems as if I can feel it in the chassis.Not a squeak type noise. Loud and easy to hear when turning in parking lot, or slower corners (25 mph ).Thought it may be cause by control arm. Grab hold of the tire when on jack stands and has no excess play up or down or side to side.Place floorjack under tire and raised,didnt make any noise. Pryed on & checked all the control arm related suspension parts,seems ok. Can reproduce noise when crawling at idle speed going straight and jam the brake on, back up 5 feet and jam brake again, and by crawling over 2 by 4 wood studs. The lower & upper ball joints has the rubber boot intact.Starting to think ball joint. Has anyone had this problem & fixed. 1990 SC 121 K miles

Arizona 02, Chris in AZ,

CFThunder
05-14-2004, 06:18 AM
Try and tighten your subframe bolts. I had a similar problem and it was the bolts just loose. Hope it helps!! Jerome

XR7Kurt
05-14-2004, 07:16 AM
How do you tighten the subframe bolts? Can you get a wrench on the nut of all those bolts or will they tighten from the head on the bottom? Also, what size is that torx socket needed for the bolts?

Ariz02 I've replaced many front end parts over the last few months and the noise didn't go away. I finally found out about these subframe bolts. I have a thread in the Florida section where a couple of other guys have also said they had the same problem and tightening the subframe fixed it.

XR7Kurt
05-14-2004, 12:57 PM
Answers to my own questions:


Can you get a wrench on the nut of all those bolts or will they tighten from the head on the bottom?
Yes, at least mine did up to 100ftlbs which was enough to stop the front end noise.


Also, what size is that torx socket needed for the bolts?
E-18 externl torx socket, $5 at autozone.

Does anyone know if there is a torque sped for these bolts? I'm thinking they need to be higher than 100ftlbs.

Kurt

Ariz02
05-15-2004, 07:49 PM
in the frontend on pass.side in the area of the wheel. Seems as if I can feel it in the chassis.Not a squeak type noise. Loud and easy to hear when turning in parking lot, or slower corners (25 mph ).Thought it may be cause by control arm. Grab hold of the tire when on jack stands and has no excess play up or down or side to side.Place floorjack under tire and raised,didnt make any noise. Pryed on & checked all the control arm related suspension parts,seems ok. Can reproduce noise when crawling at idle speed going straight and jam the brake on, back up 5 feet and jam brake again, and by crawling over 2 by 4 wood studs. The lower & upper ball joints has the rubber boot intact.Starting to think ball joint. Has anyone had this problem & fixed. 1990 SC 121 K miles

Arizona 02, Chris in AZ,

FIXED THE PROBLEM
TIGHTEN THE SUBFRAME BOLTS USING A TORX #E18 SOCKET, 1/4 TURN WAS THE MOST IT NEEDED, 4 BOLTS PER SIDE,1/2 INCH CLICK TORQUE WRENCH @ 90LBS W/6 INCH EXTENSION ON 1/2 TO 3/8 SOCKET ADAPTER FOR E18, 90#IS A LOT ON THE 3/8 DRIVE CHROME E 18 SOCKET,SUPRISED SOCKET DID NOT BREAK.