PDA

View Full Version : Werid Blower Noises



fastsc92
05-13-2004, 10:17 PM
Ok, a few days ago i changed the front seal on my blower for the second time in a few months. I figured i didn't put it in right the first time or i nicked the sealing lip. Anyhow, i took the blower apart cause the oil looked kinda dirty. I didn't touch any bearings. I just pulled the halves apart wiped the dirty oil out and sealed everything back up using anaerobic gasket sealer. I bolted it all back together and now i hear some weird noises.

The blower spins feely and no noises come from it that way. When the car is idling you dont hear much, but when the car is still under vac. and you tap the gas there is a whine that sounds exactly like the power steering whine. However...this noise is noticable in the car, and when i tap the gas...i still dont reach boost. Once under boost i can hear the normal blower whine...but that other noise is still noticable on top of the blower whine. Something just isn't right....what did i do wrong? Everything seems to be crapping out on me all at once. Help me out guys.

keithw
07-28-2004, 08:45 AM
Is there part of a gasket getting near the rotors? Blowers will make some noise. Every SC that I have heard makes some noise, even without boost. Maybe I am wrong.

J57ltr
07-28-2004, 09:06 AM
Did you put the coupler in backwards?

Jeff

fastsc92
07-28-2004, 04:51 PM
i think i posted in another thread what ended up happening. While the tubes were off...i stuffed a rag in the IC to stop sealant and other stuff from falling in. Well i was in a rush and dumb me forgot to take that rag out. :eek: The noise was most likely from a huge backpressure problem. Took it out and all is well. :cool: Sometime we all do dumb things i guess.