PDA

View Full Version : New Engine, High Idle



dastalka601
08-02-2004, 06:26 AM
Just recently finished installing a new engine in my '91 SC AT. Everything seems to be working fine except for a high idle(1500-1800RPM). If I snap the throttle the idle sticks around 3,000RPM. Have done everything I can think of! Ran the Fog machine and can see no vacuum leaks, just replaced the Idle air control valve(corrected intake noise problem, but not idle!). I am very new to SC's, is there anything that I could check? Anything that it could be? Any help would be greatly appreciated!
Thanks,
Chris
[email protected]

minn95scya
08-05-2004, 08:31 PM
Replace your tps senor on the thottle body. I had the same problem with my new engine too. Give it a shot!!
Just recently finished installing a new engine in my '91 SC AT. Everything seems to be working fine except for a high idle(1500-1800RPM). If I snap the throttle the idle sticks around 3,000RPM. Have done everything I can think of! Ran the Fog machine and can see no vacuum leaks, just replaced the Idle air control valve(corrected intake noise problem, but not idle!). I am very new to SC's, is there anything that I could check? Anything that it could be? Any help would be greatly appreciated!
Thanks,
Chris
[email protected]

darkstar_one
08-05-2004, 09:49 PM
hey dude
from experience please do not drive ur car, take a taxi to the nearest ford dealer and get urself a genuine IAC valve, ur valve is shot and causing ur IDLE to be high, please dont drive since its an automatic, i ruined a perfectly rebuilt transmission due to a messed up iac valve in one day, it was painfull but i learned my lesson. please do not drive the car, go get a IAC valve first. lates

TbirdSCFan
08-05-2004, 11:05 PM
just replaced the Idle air control valve(corrected intake noise problem, but not idle If you got an aftermarket IAC, then thats the problem. The Autozone, pepboys, oriellys, and Napa :eek: have to be mounted backwards. They don't work on the SC due to the position of the oil filler tube. You need a Ford IAC or eqivalent. The proper one has a white nylon bellows inside and NO wire lead. :)

badtoyz
08-05-2004, 11:15 PM
Mine 91 sc auto was Idleing high went to ford and 105.00 later its running great! Also when you take your old one off look down inside it and see ifthe bellow is broke or torn away mine was. Good Luck!

vetteman
08-06-2004, 05:55 PM
before spending alot of money take your Idle Air Control valve off your throttle body and then take the little screws out and remove the selenoid, then take some starting fluid and clean the inside of the valve,make sure that the valve moves back and fourth freely. You should be able to close it manually and blow no air threw it then release it and have a minimal amopunt of air blow threw. This problem ussually accours when an engine is replaced or the engine is worked on with the intake tubes or air box is removed and a piece of grime gets stuck in the IAC valve seat
hope it helps ,Vetteman





89 SC 5 spd
76 Vette
84 Vette
87 Vette
70 GT torino