PDA

View Full Version : fuel pump problems



bigg_boyys_SC
08-22-2004, 06:59 PM
Me thinks me fuel pump is shot. I have 30# at idle and only 40# at boost. Now, the thing that makes me think it is bad is the fact that as soon as I turn the key off, the pressure drops off to nothing very quickly. My repair manual says that I should have pressure out to 5 minutes. As far as posible causes it isn't specific, they list the pump, regulator, or leaks in the line. I have ruled out the leaks in the line, well at least from the tank to the engine, may be leaking in the tank but un likely. Also it takes a while to start in the morning, and after it cools off. The car is lossing large amounts of power in the upper rpm range anything past 3300 and it falls on its face. Any body have these problems and can give some insight.

Thanks, Biggin'

jwhit
08-22-2004, 08:20 PM
Me thinks me fuel pump is shot. I have 30# at idle and only 40# at boost. Now, the thing that makes me think it is bad is the fact that as soon as I turn the key off, the pressure drops off to nothing very quickly. My repair manual says that I should have pressure out to 5 minutes. As far as posible causes it isn't specific, they list the pump, regulator, or leaks in the line. I have ruled out the leaks in the line, well at least from the tank to the engine, may be leaking in the tank but un likely. Also it takes a while to start in the morning, and after it cools off. The car is lossing large amounts of power in the upper rpm range anything past 3300 and it falls on its face. Any body have these problems and can give some insight.

Thanks, Biggin'
it sonds like pump is toast have you changed filter?if not change filter and recheck with motor idling prresure should be 35-40 psi unhook vacum line that goes to fuel pressure regulator then pressure should go up to 50psi also rev motor up and see if pressure drops (with vacum line unhooked) if it does go ahead and change pump . i have got to change my pump also my car runs great untill you start getting the rpms up also if i go beyond 6psi boost it almost cuts off . just fyi the pressur gyage i have hold preesure after car is off for about 7-8 mins it might be the gauge you have or fuel presure reg might be leaking good luck