PDA

View Full Version : Car is hesitating



Brandon
09-06-2004, 05:46 PM
Ok, here's the scoop...2 Fridays ago I installed an MPII, MP inlet, MP throttle body, 42lb injectors, and an adjustable FPR. The car ran awesome until this past Tuesday. Then it began to run rough and wouldn't hardly idle. I took it to the track on Wed, where it was still idling rough, but managed a 13.66 @ 102mph. The car was still running strong, but idling rough. I managed to take care of the idle, by adjusting the idle screw and putting a couple nuts on it to keep it from moving. The car began to hesitate upon full throttle though. It was running rich (lots of black smoke from the exhaust). I bought a fuel pressure tester and hooked it up and adjusted it. Kept trying it at different pressures and the car still hesitated and blew black smoke (although not as much). I adjusted it down to where the fuel pressure was about 40 static and the car finally felt strong, but still has a hesitation at full throttle. It still blows a little black smoke too. I also checked the oil and it has some small bubbles in it, but no signs of milkiness. The coolant looks a little cloudy, but nothing really bad looking. That's how the car sits as of right now. Any ideas?

scbird1
09-06-2004, 09:08 PM
Im no expert but I think you need a chip and your maf needs to be calibrated with the larger injectors. Also when ever I did a mod I unhooked the battery for about ten min. Computer relarn. Someone with extensive mods needs to chime in here.

Brandon
09-06-2004, 10:49 PM
Im no expert but I think you need a chip and your maf needs to be calibrated with the larger injectors. Also when ever I did a mod I unhooked the battery for about ten min. Computer relarn. Someone with extensive mods needs to chime in here.

I may need a chip, but I bought the correct sampling tube for my MAFS. I unhooked the battery of course, while I was putting the new parts on.

007_SuperCoupe
09-06-2004, 11:32 PM
The car began to hesitate upon full throttle though. It was running rich (lots of black smoke from the exhaust). Kept trying it at different pressures and the car still hesitated and blew black smoke (although not as much). It still blows a little black smoke too. Any ideas?


Check for vacuum leaks...and when you're done checking, check again...You had all your plumbing off. Double check every vacuum line and IC joint 2x. I'm sure it's a vacuum leak.

Brandon
09-07-2004, 06:47 AM
Check for vacuum leaks...and when you're done checking, check again...You had all your plumbing off. Double check every vacuum line and IC joint 2x. I'm sure it's a vacuum leak.

It's pulling the same vacuum as it was before the MPII swap.

007_SuperCoupe
09-07-2004, 07:30 AM
It's pulling the same vacuum as it was before the MPII swap.

It can pull the same vacuum at idle according to the guage and still have a vacuum leak...I've had it on BOTH of my SC's now. All I'm saying is start small and eliminate the really easy stuff to fix first, no matter how small it may seem.

Brandon
09-07-2004, 07:10 PM
It can pull the same vacuum at idle according to the guage and still have a vacuum leak...I've had it on BOTH of my SC's now. All I'm saying is start small and eliminate the really easy stuff to fix first, no matter how small it may seem.

On second thought I looked at the vac today and it was only pulling 12-14 where normally it pulls 18-20. Hmmm...was fine the other day! I'm going to look into that tonight.

Brandon
09-11-2004, 01:04 PM
On second thought I looked at the vac today and it was only pulling 12-14 where normally it pulls 18-20. Hmmm...was fine the other day! I'm going to look into that tonight.

I checked for vac leaks with carb cleaner...I can't find any! I even pulled the plastic inner fender out from the driver's side to see if I had any leaks under there after a recent fender swap. Nothing! Car idles fairly decent, but lots of black soot and condensation from the exhaust.

Jake
09-11-2004, 02:46 PM
If you have an air compressor you can pressure check the system. The how to is in the FAQ members section. When I did mine I found 3 good leaks and 4 very small ones, and I didn't think I had any leaks at all.