PDA

View Full Version : check engine light/ miss at idle



lowflying90
06-22-2002, 05:21 PM
ok, here's my problem.....recently the check engine light started coming on occasionally at idle. my car has also developed a miss. i changed cam sensors but that did not solve the problem. I have a 70mm maf on my car. i have had it on my car for 2 months now and the problem just started. I put the 55 mm maf on and the miss seemed to have went away. I took the electronics off of the 55mm and put it on the 70mm. It seemed to be ok for like a minute, then the miss came back.....The miss seems to be at like 900 rpm that it occurs.

Thanks,
Jeff

Digitalchaos
06-23-2002, 03:57 AM
This sounds like a fuel delivery problem. Perhaps when you switch to the larger maf, the cpu cannot send enough fuel to compensate for the extra air to prevent detonation. This could be caused by things like a worn fuel pump, clogged fuel filter, or dirty injectors. Does the ping exist or increase at higher rpm?

lowflying90
06-23-2002, 04:06 AM
tonight, it seems that the miss is no longer happening i have the 70mm maf with the electronics from the 55 mm maf in it, but when i leave off the gas when the car is warm, the check engine light comes on, when i give it a little gas it goes out. the car keeps running ok the whole time.

Thanks,
Jeff

Digitalchaos
06-23-2002, 04:10 AM
It could be the maf sensor going bad. Do you have a code scanner? If not, take it over to autozone and tell them to scan it for you. They will, for free. That may solve your problem.