PDA

View Full Version : Pitching the power antenna



mduralia
11-24-2004, 01:29 AM
For the last year, the power antenna has continued to run after it has fully extended or fully retracted. It ~~~~ annoying so I'm going to replace with a standard "fixed" antenna. I did this before and when car was wrecked body shop installed electric again.

Anyhow, this time much more difficult. Anyone know the part number for the plastic "bushing" that the antenna passes through in the fender? :confused:

Anyone else made the swap and have any suggestions for anchoring the darn thing? :mad:

Thanks.

68COUGAR
11-24-2004, 02:57 AM
Instead of giving up on the whole pwr. ant. idea, think "Outside The Box"

How about replacing your Radio with some thing more Intellegient?

Buy a Head Unit that ONLY raises the antenna when the AM/FM/ is ON. When the Radio is OFF, the antenna comes down!

No Antenna with SAT/Cass

Simple Solution!

68COUGAR

mduralia
11-25-2004, 06:04 PM
Instead of giving up on the whole pwr. ant. idea, think "Outside The Box"

How about replacing your Radio with some thing more Intellegient?

Buy a Head Unit that ONLY raises the antenna when the AM/FM/ is ON. When the Radio is OFF, the antenna comes down!

No Antenna with SAT/Cass

Simple Solution!

68COUGAR

Not quite. Problem is not it going up an down all the time. It does work with the head unit properly but doesn't "know" when is all the way up or all the way down so it just keeps clicking, clicking, clicking.

I've about got it figured out...watched an episode of MacGyver the other night and got inspired...we'll see.

Michael Mattix
11-29-2004, 01:09 AM
I replaced the mast from Ford about a year ago. What a mistake. Go and search on ebay and you'll find a brand new replacement motor and mast for buy it now 29.99. That is what I'm going to do when this one gives out.

mduralia
11-29-2004, 09:10 PM
Well, it took way too long but I finally made enough MacGyver parts to make it work. Looks pretty good. When I have a chance, I'll post some pics.

Best part...no more "click, click, click" each time I turn the ignition :)

rogcern
04-04-2006, 12:05 AM
Just saw an old thread of yours, had a broken mast on my 94' SC got one from the bone yard (whole motor/with mast ) ---cleaned it, WD-40 and works well,goes up and down when shut car off or turn radio off ------- then it keeps click-click-click for 30 seconds , sounds like you found problem. P L E A S E Help! Roger Call on my dime or E-mail rogcern@excite.com 866-204-4587

adpsmp
04-04-2006, 12:23 AM
I had the same problem, I had a shop replace the motor and gear and it has worked perfect since

Spider
04-04-2006, 01:03 AM
cant you cut a wire to the motor when its all the way up then it will stay up ?

thirdbird
04-04-2006, 01:58 AM
I used the radio so seldomly, that the one bird with a broken antenna, I just shoved the thing back into the fender(while someone held the down button).
The reception was not much different with the mast down than up(FM).
I have an MP3 player, so I dont run outof music ever....

paul