PDA

View Full Version : ok im stuck



importkiller
11-30-2004, 12:31 AM
ok im stuck i've recently finished my hg. now i've noticed that the car is running fine except for the white smoke coming out of the back. i don't think it could be the head gaskets b/c i've only driven the car ten miles to get gas. also checked oil all looks ok, but i also noticed that the injectors sound different on the drivers side than they do on the pass. pass side seems to be moving quicker than drivers.

i also pulled codes from the car and it gave me that both o2 senors are riunning lean. those are getting changed this weekend but anyone else have any ideas as to what is going on figured might as well buy everything i need
:confused:

importkiller
11-30-2004, 12:52 AM
oh i also forgot to mention that it doesn't smoke right away but after i run the car for at least 5 min.

scirs90and93
11-30-2004, 12:59 AM
is it steam or smoke? if it a white steam then you could still have hg problem. check and see if the water is low in the radiater. just a thought. you could try a can of the copper or silver radiater leak fix. if it makes it go away then you can bet you have a sealing problem.

mike

scbird1
11-30-2004, 01:32 AM
Just keep driving it. Change out the o2`s and let the rest of the antifreeze burn out of the exhaust. Every car I repleaced these on still smoked for days after but went away. Hang in there.

importkiller
11-30-2004, 03:28 AM
its not heavy very light smoke. 1st i'm gonna try the o2 then i'll try the injector and go from there